Twitter thumbnail not showing image


#1

every time i try to tweet about an article our site just released (healthlifeandstuff.com) the thumbnail just shows the typical grey lines with no image (with this article for instance: https://healthlifeandstuff.com/alzheimers-disease-product-reviews/alzheimers-new-treatment-approach/ ). Would love some help on this. Thank you!


#2

name="twitter:image" content="/wp-content/uploads/2019/01/Unknown-1.jpeg"

This is a relative URL, you need to use an absolute URL for this to work.


#3

how would I do that? put the actual url of the image where i found the image in the image description in wordpress?


#4

Using https://healthlifeandstuff.com/wp-content/uploads/2019/01/Unknown-1.jpeg should work ok.


#5

not working. would it have something to do with a plugin (i deactivated smush to see its effect to no avail?


#6

Do you have any caching going on? I’m not seeing a change to the image URL field.


#7

Thanks for getting back to me. im using W3 total cache (not sure if that answers your questions, sorry im not super familiar with these terms).


#8

It answers my question, but unfortunately I’m not familiar with how to help you to clear the cache so the new value for the image tag might be seen on our side.


#9

No worries. i purged the cache for the post but the image still doesn’t show in the thumbnail. any other ideas?


#10

The image on your web page is still relative path not absolute:
<meta
name=twitter:image content=/wp-content/uploads/2019/01/Unknown-4.jpeg>

It might be worthwhile to disable W3 total cache plugin while you get the twitter card working and once it starts working reactivate it.
You need to see absolute paths when you do “view source” on your page before the card would work.
Also note that after you fix it, the bot might not pick it up right away as it caches your old schema (so it might take few hours), but the first step is seeing absolute path on “view source”


closed #11

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.