Twitter Summary Cards not displaying image correctly (validator OK)

wordpress

#1

Twitter is not showing images on posts links from my website. A grey image holder is displayed instead of the feature image.

WEBSITE & POST URL
http://www.romanroadlondon.com (wordpress)
http://romanroadlondon.com/growing-concerns-victoria-park-bow/

BACKGROUND
Twitter hasn’t been showing images from this website for YEARS! They did used to in 2015/2015 but now they don’t. (I have been focusing on Facebook and Instagram so haven’t got round to trying to fix this but now want to grow Twitter) All the most obvious settings seem to be correct (see below). I have a wordpress site. I recently added the several plugins to help with site speed. However I have since deactivated this while I try to resolve my long standing Twitter card image problem. Please note: I am not a developer - just a self-taught blogger.

Q. When I reactivate site speed/caching/compression/disable plugins, are there any that might affect whether a Twitter summary card displays image correctly?

CARD VALIDATOR
https://cards-dev.twitter.com/validator
*.romanroadlondon.com is whitelisted for summary_large_image card

INFO: Page fetched successfully
INFO: 26 metatags were found
INFO: twitter:card = summary_large_image tag found
INFO: Card loaded successfully

IMAGE SIZE
Image file: Growing-Concerns-Victoria-Park-Bow-04.jpg
Image size: 600KB
Image dimensions: 1500 x 1000

ROBOTS.TXT
User-agent: *
Disallow: /wp-admin/
Allow: /wp-admin/admin-ajax.php

URL
When I copy the URL from the webpage it looks like this: romanroadlondon.com/growing-concerns-victoria-park-bow/. But when I paste it into Twitter it looks like this: http://romanroadlondon.com/growing-concerns-victoria-park-bow/

Q. So does this mean my URL is absolute or relative? Should it be one or the other? How do I change this?
Q. Is it because the protocol is http and not https?

YOAST SETTINGS
In Yoast > Social > Accounts my Twitter handle is listed (not the URL but just the username as requested)
In Yoast > Social > Tiwtter > the ‘Add Twitter card meta data’ is Enabled
In Users > Profile my Twitter name is listed
In the post I have uploaded the feature image for Twitter in the plugin

VIEW SOURCE
meta name=“twitter:card” content=“summary_large_image”
meta name=“twitter:description” content=“Tucked away at one corner of Victoria Park is Growing Concerns, our local, leafy garden centre. We talk to owner and founder Caroline Walker, to discover how this social enterprise has become a thriving local business.”
meta name=“twitter:title” content=“Growing Concerns, a not-for-profit garden centre | Roman Road LDN”
meta name=“twitter:site” content="@romanroadldn"
meta name=“twitter:image” content="/wp-content/uploads/2018/04/Growing-Concerns-Victoria-Park-Bow-04.jpg"
meta name=“twitter:creator” content="@romanroadldn"


#2

meta name=“twitter:image” content="/wp-content/uploads/2018/04/Growing-Concerns-Victoria-Park-Bow-04.jpg"

You need to use an absolute URL. Try adding http://romanroadlondon.com to the start of the URL in that tag.


#3

Hi AndyPiper. Do you mean that I need to add http://romanroadlondon.com in the content tag you extracted above eg content=“http:/romanroadlondon.com/wp-content/uploads/2018/04/Growing-Concerns-Victoria-Park-Bow-04.jpg”

I’ve just gone to Inspect source again and i actually does display the protocol as above (not quite why it is showing that now when it wasn’t before). But it still doesn’t show image.

Do I need to change a setting on the website to make sure absolute URLs continue to be used? How do I do this? Will this create broken links?

What else could I try seeing as adding the protocol into the meta tag hasn’t solved it?

Thanks for your time.


#4

Hi @andypiper. Any other thoughts if it’s not to do with the absolute URL (see earlier response from me - the code on the page does actually include the full URL). Thanks!


#5

I’ve just validated the page and posted a link and the card renders just fine, so I think your issue here is solved?


#6

@andypiper I apologise. I promise I did check just prior to messaging you again - ten minutes later it seems to be working! I guess it may have resolved itself after i deactivating the site optimisation plugins yesterday and these may have taken a while for WP to update/cache/process. Thanks for your help in any case. Much appreciated.


#7