Twitter spend API failure


#1

Hey folks,

I am Yaning from uber marketing data platform team. Nice to meet you!

Today we had some API failures of pulling yesterday’s ads spend data on twitter for account “18ce53ywppc”. API simply failed our pulling request again and again.

Can you help fix this issue as soon as possible?

Specifically, our request was rejected when we tried to call this API:

=====================CODE=========================
Request(client, ‘post’, ‘/1/stats/jobs/accounts/18ce53ywppc’, {‘placement’: ‘ALL_ON_TWITTER’, ‘metric_groups’: ‘ENGAGEMENT,WEB_CONVERSION,MOBILE_CONVERSION,MEDIA,VIDEO,BILLING,LIFE_TIME_VALUE_MOBILE_CONVERSION’, ‘start_time’: ‘2016-10-30T00:00:00+02:00’, ‘entity’: ‘CAMPAIGN’, ‘end_time’: ‘2016-10-31T00:00:00+02:00’, ‘granularity’: ‘DAY’, ‘entity_ids’: u’2do3g,2do4n,2g5o7,2gc9a,2gc9s,2gyga,2gyps,2gyvy,2hpi0,2hpl0,2klhe,2klia,2klkp,2klmn,2na5l,2na6v,2nad2,2nad5,2naqm,2naqw’}
[2016-10-31 21:00:33,183 INFO] Starting new HTTPS connection (1): ads-api.twitter.com
[2016-10-31 21:00:33,336 ERROR] {‘msg’: u’Failed to get job_id for: 18ce53ywppc’})

Best, Uber marketing data platform team


Twitter ADs API spend Failures
#2

@Uber_Hack: Thanks for the question. We tried to reproduce with a synchronous stats call and got the following error.

{
  "errors": [
    {
      "code": "INVALID_TIME_WINDOW",
      "message": "Expect time to be midnight in the account's local timezone for day granularity",
      "parameter": ""
    }
  ],
}

Please see the Analytics documentation for more information.

For DAY granularity, if no timestamp or offset is specified, the date will default to the correct timezone.

Please let us know if this helps.


#3

Hi all, could it be due to recents time changes, regard to winter-summer times?

We had some problems related to this in the past. We solved it working always in GMT.


#4

@Uber_Hack: Were you able to successfully request the stats data?


#5

@Uber_Hack: If this resolved the issue, please mark this thread as solved.


#6

Hi,

I am kishore who works for uber data platform team. Today we are not able to connect to API despite trying at different times. In every try our connector tries to keep on establishing connection for 40 minutes-1hr and then fails with error message “Max tries exceeded”. I have attached relevant screen shot, could you please look into it and fix it as soon as possible.

Thanks


#7

@Uber_kishore: Your question is unrelated to this topic. Please start a new one and provide the relevant information as outlined in Guidelines for Reporting Issues.


#8