Twitter Share Buttons won't share


#1

I have had a problem for over a year with my Twitter share buttons I have removed all of them except for one. I believe the problem is because of my initials at the beginning of the tweet. If you backspace the name off, the tweet will send. I have tried in vain to find a resolution. It worked prior to last January. Can someone please assist me?


#2

Are you using the Tweet button or a Tweet web intent?

It seems like the web intent window opens as expected but you are having issues sending the prefilled Tweet text? Can you please provide an example URL causing this behavior?


#3

Thanks for your response, Niall. I am using the Tweet button. I uninstalled my Twitter widget and the Twitter share button that is on Google Blogger because my readers kept complaining. Here is a screen shot.


#4

Hi Niall,
Were you able to figure out what the problem is with my account? I really appreciate your help.


#5

Starting a Tweet with an M like this is an SMS shortcode for sending a direct message. That’s why you see this error.


#6

How can I change it?


#7

Unfortunately this is a built-in behaviour. You’ll have to change your Tweet text to not start with "M. "


#8

That is the way that Twitter shares it. How can I change it?


#9

If you use the text parameter on your link for the Tweet Button you can specify any alternative text that you like, just avoid starting with M or D which are both SMS shortcodes.


#10

Wow! I cannot thank you enough for your help! I have my Twitter button back.


#11