Twitter scripts with No Error & w3c Validation


#1

Trying to build a site, with social plugins but nothing is straight forward,

You fix one thing and something else breaks any tips and advice would be very welcome

Thanks

Wayne

W3C VALIDATION 2 ERRORS

Line 35, Column 76: there is no attribute “data-lang”
…ttps://twitter.com/share" class=“twitter-share-button” data-lang=“en”>Tweet

You have used the attribute named above in your document, but the document type you are using does not support that attribute for this element. This error is often caused by incorrect use of the “Strict” document type with a document that uses frames (e.g. you must use the “Transitional” document type to get the “target” attribute), or by using vendor proprietary extensions such as “marginheight” (this is usually fixed by using CSS to achieve the desired effect instead).

This error may also result if the element itself is not supported in the document type you are using, as an undefined element will have no supported attributes; in this case, see the element-undefined error message for further information.

How to fix: check the spelling and case of the element and attribute, (Remember XHTML is all lower-case) and/or check that they are both allowed in the chosen document type, and/or use CSS instead of this attribute. If you received this error when using the element to incorporate flash media in a Web page, see the FAQ item on valid flash.

Line 36, Column 8: required attribute “type” not specified

!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElem… The attribute given above is required for an element that you've used, but you have omitted it. For instance, in most HTML and XHTML document types the "type" attribute is required on the "script" element and the "alt" attribute is required for the "img" element. Typical values for type are type="text/css" for and type="text/javascript" for . CHROME ERRORS Unsafe JavaScript attempt to access frame with URL http://platform.twitter.com/widgets/tweet_button.1354761327.html#_=1354866975498&count=horizontal&id=twitter-widget-0&lang=en&original_referer=http%3A%2F%2Fwww.search4sun.com%2Ffacebooklikes.html&size=m&text=Untitled%20Document&url=http%3A%2F%2Fwww.search4sun.com%2Ffacebooklikes.html from frame with URL http://www.search4sun.com/facebooklikes.html. The frame being accessed set 'document.domain' to 'twitter.com', but the frame requesting access did not. Both must set 'document.domain' to the same value to allow access.

#2

got the exact same problem. any solution found yet?


#3

open the link in the error…that will open up tweet button use chrome’s default console and see the script that document.domain set the twitter.com…i know this is causing the problem … but how can i set this to my domain…


#4