Twitter Publish is not working


Twitter publish for profile embed on html is not working. It only shows “Tweets by xxxx”.


The HTML snippet generated on should contain two parts: a specially-formatted link to your Twitter profile and Twitter’s widgets JavaScript to convert the link into a fully-rendered widget.

Check to make sure the HTML you are copying into your website contains the <script> with Twitter’s widgets JavaScript.

Paste the generated markup into your webpage source or an area of your website generator such as a CMS. View the published page. View source and search for If it does not appear similarly to your copied HTML markup then your site’s software is removing the JavaScript component.


Hello, I tried everything. been at this for 2 days probably 8+ hours. Most Google help I found goes back to 2013. So I am posting here.

I am like a 2.5 on the programming scale out of 10. I have tried what you said. I pasted the code into a text widget? No go.
I have changed the (// to…

I am using WordPress 4.7.1 running SuperMag theme.

I have tried Elicit theme, Iconic One theme, Steed theme all by different devs. Nothing.

I tried what you said, Paste in widget, check the outcome, then check the widget to see if it changed the java script.
Nope. Still says // Or what is was when I pasted it.

Here here is my widget text…

<a class="twitter-timeline" data-width="300" data-height="600" href="">Tweets by XXXXX</a> <script async src="//" charset="utf-8"></script>

Any idea? I can’t wait until Twitter updates to their next revision. I want my widget back, this problem is on two of my sites. I have been with this problem for 2 months hoping Twitter updates. I took the first site’s widget down.

The other site had an issue that the widget would start to generate then disappear. Leaving only “Tweets by XXXX”.
For that one I was using the widget ID and the JetPack plug-in.

Any ideas would greatly be appreciated.

Other relevant info: No Adblocker, No No Script blocker, am using Chrome Version 55.0.2883.87 m

Logged in to WordPress using Incognito Mode (no extensions)… shows, then disappears.

[ Solved ] Here is how: All of those theme had an option “Sticky sidebar”. If you choose this option… it MUST cancel out the java script. WORD TO THE WISE. Once I turned off… Whalla workie, workie.

I hope it holds up?

I hope those searching… find this answer.

I apologize for bothering you busy folks. Two days smh.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.