Twitter profile widget stopped working in Wordpress - how can i fix it?


#1

For the last year, I’ve been using the Twitter Profile Widget from

https://twitter.com/about/resources/widgets/widget_profile

on my self hosted Wordpress page - without a problem

Suddenly its stopped working. Nothing is showing. The code hasn’t changed - I’ve pasted in a backup copy just to check.

Has anyone had the same problem?

Any solutions?

At the time the profile widget stopped, NOTHING had changed on my Wordpress site. (Incidentally the code still works on the Twenty Twelve default theme - not that that’s any good to me!)


#2

Can you share a link to your blog so we can check it out? What does “not working” in this case mean? Have you verified if it’s just not working for yourself when you view it versus not working for others? Which browsers are you using?


#3

Hello,

The widget I created with your widget tool has also stopped working for me in the last day; you can see it here, at the very bottom of the following page:-

http://www.sparsholtandwestcot.org/

The code your widget tool created for me uses a list (https://twitter.com/#!/JoshnTobesDad/for-sparwest) and is as follows; hope to hear from you!

Many thanks,

Nick


#4

Hi Taylor

Sorry, I’ve only just seen your reply.

You asked for a link.

This is how the code looks on a Virgin Wordpress site:
http://test7.nickwingfielddesign.co.uk/?page_id=73

Here is exactly the same code on the site that doesn’t work for me:
http://test10.nickwingfielddesign.co.uk/get-in-touch/twitter-code

I have now tested the latter site on various computers with various browsers. The results are surprising:

On PC running Windows 7, the Twitter profile doesn’t show on Chrome or IE9

On Mac (OSX 10.7.4), the Twitter profile doesn’t show on Safari, Firefox or Chrome. BUT it DOES show on Opera!

Also, the Twitter profile DOES show on Safari on iPad2 but not on iPhone.

Weird?


#5

Further update to my browser tests above:

I’ve just run the same test again on Opera on the Mac and Safari on iPad2. Now even they don’t show the Twitter Profile! Why they worked 24 hrs ago and don’t work now - I have no idea. Weirder and weirder!


#6

SOLUTION!

Just in case there’s anyone out there reading my posts apart from me:

Just got Twitter feed working again!

I thought I’d try disabling Wordpress plugins one by one. Should have done it in the first place!

When I disabled a plugin called ‘HumansNotBots - Easy, Accessible Email Cloaker’ - the Twitter feed re-appeared!

It’s still a mystery as to why that plugin is the problem. As I said, at the point when the Twitter feed stopped working, I hadn’t done anything. I hadn’t updated Wordpress or updated any of the plugins. Plus, the site had been running for several months with all the plugins working including the one above.

I’d still be interested if anyone has an explanation?


#7

I’m having a similar problem. Until two hours ago my twitter plugin was working, and then it just stopped working,it still shows the color and “join the conversation” but no feed. The website is http://amelia-rivera.com/Bio.html and I haven’t changed the feed. I also tried to generate a new one but it didn’t let me do it. Is it a problem on my end?


#8

I just went to your site and your feeds seems ok. Does it work for you now?

If not, what browser/version are you using?


#9

Mine says they are upgrading someehting. and then it takes me to word press where it won’t accept my user name or password I’m on a mac mini10-3-4


#10

Did anyone get my note?
can anyone help me


#11

I got a Mac in case anyone knows about macs


#12

they are doing a domain mapping upgraade what ever that is it won’t tale my user id or password


#13

I got wordpress to work by regidtering for it


#14

I cannot authorize followed directions.


#15

www.drbpope.com


#16