Twitter Profile Widget not working


#1

On my website the widget isn’t working.

When using profile widget builder at https://twitter.com/about/resources/widgets/widget_profile, it is also not working.

Behavior occurs for my personal and public account.

Please advise.
Thanks.


#2

The same thing is happening to me. Right now it looks like most of the widgets for ‘My website’ except for the Search Widget aren’t working.


#3

Just checked it out a few seconds ago. Appears to be fixed and working for me. See the profile widget at http://nyuinformatics.org.


#4

I just checked your site and it’s not working for me. I had been looking into the “Rate limit exceeded” threads, which is the error I’m getting, but I doubt 150 people from my IP had gone to your site in the past hour - and I would think Twitter’s own widget builder would not be hit 150 times from people at my IP. So I’m skeptical that’s the only issue.


#5

hmmm, where did you see the error message? I just checked my site again and it seems to be working fine. Also the profile widget builder from above is working as well.


#6

I had been seeing the error in the Net tab on Firebug. The response from the GET is

“TWTR.Widget.receiveCallback_1({“error”:“Rate limit exceeded. Clients may not make more than 150 requests per hour.”,“request”:”/1/statuses/user_timeline.json?screen_name=twitter&callback=TWTR.Widget.receiveCallback_1&include_rts=true&count=4&clientsource=TWITTERINC_WIDGET&include_entities=true&1324077096143=cachebust"})"

There are a few threads on this issue here. I just find it really hard to believe that Twitter’s own widget builder is falling victim to this. When I was coding my page, it worked every time, now all of a sudden it’s intermittent.


#7

is the url of your page available?


#8

This is the page I have the widget on:
http://www.tivo.com/mytivo/connect-with-us/index.html

Perhaps it is just the rate limiting - but I’m trying to figure out how I’m adding up to 150 in an hour and how to work around it.


#9

Just visited your site. Works for me.

Perhaps the requests are getting routed through a proxy, and twitter is getting confused by the traffic coming through it.


#10

Oh that’s a good point! Thanks.


#11

tak mengerti akan diri sendiri


#12

I am having problems too on my blog @ netdiversitiy.ca/blog.
My profile picture and text are not at same height. This is the same cut and paste code. Am I missing something else here?


#13

Did anyone find the solution/workaround for this issue? When viewing this from a campus or large corporation, you can hit this limit pretty quickly. I’m using the list widget, which is perfect for what I need, but just keep getting the rate limit error.


#14

If you’re concerned that end-users would be rate limited, your best option is to not use the widgets but instead build your own solution, likely using the Streaming API or REST polling de-coupled from direct user interaction with the sites displaying tweets.


#15

Twitter widget debugged

Removed settings checks on privacy and secure https in the Twitter account settings to get it to render again on website.maybe privacy is only needed…still checking…


#16

I think we need to keep this thread up above.

I just made a customizable profile widget with the following code:

Put between the head tags:

!script charset=“utf-8” src=“http://widgets.twimg.com/j/2/widget.js”></script!

Exclamation marks are intentional to make the code appear rather than be loaded…

Put in it’s seperate

on the page itself:

!script>
new TWTR.Widget({
version: 2,
type: ‘profile’,
rpp: 3,
interval: 30000,
width: 215,
height: 300,
theme: {
shell: {
background: ‘#ffffff’,
color: ‘#707070
},
tweets: {
background: ‘#ffffff’,
color: ‘#707070’,
links: ‘#818181
}
},
features: {
scrollbar: false,
loop: false,
live: false,
behavior: ‘default’
}
}).render().setUser(‘OmniFilm’).start();
</script!

The box itself is loaded, but the tweets aren’t appearing. I tried having both scripts in the div, but the result is the same.
Also one thing I noted was that during a re-code of the page, an error occured that messed up my menu, but then the tweets were suddenly visible… just at the wrong place.
I tried looking on different browsers through 3 different ISPs. It’s the same thing all over.

I could work so well, yet causing so much trouble.

TWITTER… please respond!

website to see the problem: www.omnifilm.dk

Thank you


#17

Can you help me with my coding? idk if it’s right or not and it wont work!..


#18

I suppose it’s because of the input proxy. I have the widget in an external hosting: I can perfectly see the widget from my home computer, but no chance from our organization, inside the proxy. After reading the thread I felt quite happy to see some light in the tunnel… :))

Even better. I was moving options and changed the “profile” setup to a “search” setup, and tried to look for @twitteruser AND THIS WORKS FINE and displays all recent tweets. Hope it helps!

David


#19

Mine is not working either!

!script charset=“utf-8” src=“http://widgets.twimg.com/j/2/widget.js”></script!
!script!
new TWTR.Widget({
version: 2,
type: ‘profile’,
rpp: 4,
interval: 30000,
width: 250,
height: 406,
theme: {
shell: {
background: ‘#a4afc6’,
color: ‘#000000
},
tweets: {
background: ‘#dbd4db’,
color: ‘#000000’,
links: ‘#005eff
}
},
features: {
scrollbar: false,
loop: false,
live: false,
behavior: ‘all’
}
}).render().setUser(‘PrimorisFinPlan’).start();

on www.primorisfinancial.com.au?

I’ve re-done it a couple of times and I just get a box with no tweets in it!? Help!!


#20

The widget appears to be loading correctly for me. Maybe you’ve hit the 150 anonymous requests / hour limit from your IP address? Does switching IPs or waiting an hour help?