Twitter not loading on social share counters


I noticed in the last few days the Twitter button count on my social share plugin doesn’t load, it just spins and spins (this is on my self-hosted WordPress blog). It’s the same in Firefox, Safari, and Chrome browsers (I also tried clearing my cache/cookies) but to no avail. When I hover my mouse over the count it displays a message of “waiting for” I tried googling this but I have no comp sic/developer background to fully make sense of it. On a random but somewhat related note, I was on another website tonight and also noticed that the Twitter button on their social share icon also wasn’t loading.

This just started happening out of the blue so I’m at a bit of a loss as to what just happened for things to be different.

Any info/tips you have would be most appreciated!


Twitter does not serve any of its APIs from Twitter does not have an official share count endpoint.

We are removing share count from our official Tweet button.


If you can let us know which specific social share plugin you’re using, we can ask the developer to update it - if the code is trying to call then that is the problem, as that URL is not supported for third party code, and should never have been used.


It’s the Cresta Social Share plugin (I was using the free version 2.4.7, not sure if that makes a difference).

Thanks for your assistance.


Thanks, I’ve reported this to the plugin maintainers.