Twitter native app get crashed if I tried to open a twitter link from my app and twitter app is not signed in


#1

I am tring to open twitter link from my android app. When I do so, it shows me two options 1. open with brawse and 2. open with twitter app.
When I tried to open link with twitter app and app is not logged in, twitter app gets crashed. Twitter works fine when I try after logging in and also works fine with browser.
I am not able to understand if not logged in why it is crashing.


#2

I observed this bug in version 3.5.0 of the Twitter App, but version 4.0.1 seems to fix it.


#3

4.0.3 still crashing here when I trying to open a special (maybe also malformed URL):
05-11 23:00:34.962: E/AndroidRuntime(18797): java.lang.RuntimeException: Unable to start activity ComponentInfo{com.twitter.android/com.twitter.android.WebViewActivity}: java.lang.IllegalArgumentException: Illegal character in query at index 40: http://twitter.com/home?status=H├╝ttenweg


#4

Also when opening an the twitter App, passing the query Parameter hashtags, that is not used to generate the tweet text, but it should.