Twitter:image not working properly when posting link in Twitter

image

#1

This is the current twitter card data I have inside <head>

<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@tradukka">
<meta name="twitter:title" content="Currency exchange: United States Dollar (USD) - Argentine Peso (ARS)">
<meta name="twitter:description" content="Currencies exchange updated in real time: United States Dollar (USD) - Argentine Peso (ARS) / 1 USD...">
<meta name="twitter:image" content="http://tradukka.com/meta/359ac65be829e896c12a3126fa9c71d0.jpg">
<meta name="twitter:image:width" content="750">
<meta name="twitter:image:height" content="370">
<meta name="twitter:url" content="http://tradukka.com/currency/usd/ars">

If I send a tweet with that link, all the information is being shown in the tweet, except the image:

I also tried using the card validator:

…it fetches everything except the image.

Also, I already tried using twitter:image:src as well. The domain is whitelisted. Any ideas on why the image is not being displayed inside the tweet?


#2

Yes, the robots.txt file for the domain where that image is hosted is preventing access to the /meta/ directory where the image is located.

Additionally, you’ll want to be aware of the 7 day cache life for cards data - if you’re trying to make this a “real time” image that gets updated, that is unlikely to work, unless the URL is always unique.

More information on the Cards Troubleshooting page on both of these issues.


#3

Hi Andy, thanks for the reply. I just updated the robots.txt file, and tried a new url with the card validator: http://tradukka.com/currency/usd/ron . That URL is using this unique twitter:image url http://tradukka.com/meta/423ee685644743bfc3ae2a0eb59b62ed.jpg but i’m still getting this response:

Do you know if Twitter has a cache for the robots.txt file as well? Or could it be something else I might be missing?

ps: just to be sure, I also purged the robots.txt file in cloudflare


#4

Just tried validating this, and the image seems to be showing now. Maybe took a little while for any CDN caches to expire? anyway, seems like you’re all set from here.


#5

Yes, it’s working now. Thanks for your help!


#6