Twitter feed won't load in chrome

embeddedtimeline

#1

I have been working on a website for my department and when I load the webpage in chrome for the first time the feed appears (sometimes). Then if I revisit that page the widget doesn’t load and all that appears is “tweets by…”. I can get the feed to appear again if i clear the cache but it then breaks when I visit that page again. It works all the time in firefox, edge, and safari. The site is: dev.chem.tamu.edu/rgroup/sczepanski/index. It is currently hosted on our development server and once I get a working version it will be hosted on our live server. Any help on this would greatly be appreciated and if you need anymore information let me know.


#2

Are you running an ad blocker in Chrome? A link appearing in Chrome only, while everything loads as expected in other browsers, indicates Twitter’s widgets JavaScript did not load on the page. Some ad blocking extensions block Twitter’s widgets JavaScript.


#3

No, the only thing the computer has that might do that is Kaspersky. I tried turning it off just to see if maybe that was the cause but it still ended up with the same result. There was one thing that I tried that made it work 100% of the time. I forced it to use https and ignored the warning chrome gave me. The development server doesn’t have a certificate since it isn’t meant to be used as a live web server. The widget loaded but whenever I tried to travel back to that page via the home link it would add an “n” in front of the URL. If I remove the widget and widget.js while forcing the https, the link works as intended.


#4

I’m having trouble as well, but its a different wrinkle. ON my WP site, the twitter feed title appears, the feed appears for approx 3 seconds, then it goes away. The only way to get it back is o close the page and reoopen it. I tried clearing the cache and that didn’t work.