Twitter Cards were working now nothing?


#1

Hi everyone,

I hope someone can help me resolve my issue, everything use to work perfect then all of a sudden no cards displaying on twitter from my shares to my twitter, all other social media works great just twitter cards i get nothing apart from title and link.

I have tried and tried with the card validator, but the error i keep getting no matter what i try is:

“ERROR: Fetching the page failed because the fetcher cannot resolve the address.”

i have changed my robots.txt file to allow Twitterbot but still nothing.

my site: http://www.tech2guides.co.uk

I am thinking that my site needs whitelisting in twitter, i am not tech savy with website coding so please bare with me thanks to all for any help with this.


#2

It looks like our cards fetcher has an issue accessing your site. You may want to check with your site host that they are not blocking Twitter’s IP addresses. There is information on our troubleshooting page about this.


#3

Hi
Thanks for your quick reply, i have contacted my host and they say the ip’s are not blocked by their firewalls, they also spent all day yesterday trying to find the issue but sadly came up with nothing, they have replied to me asking if you could supply a little more detail on the issue so they can look closer at why this has happened to my server and how to fix it.

Any detailed info on this issue is highly appreciated thanks.

regards.


#4

Hi all,
We have experienced the same problem with our haptic video player. It always worked fine but now, I don’t know why, Card Validator says: ERROR: Fetching the page failed because the fetcher cannot resolve the address.

Our domain was whitelisted long time ago, URLs worked fine but now it doesn’t work correctly. Twitter behavior is very strange. When sharing any of our URLs in a post (this is an example:
http://player.haptter.com/Video/Play?videoId=3536)
The player is only shown correctly in a desktop (preview image and play button and also it plays video) but not in Twitter for mobile phones feed.

Mobile Twitter feed only shows text and the link to our URL! But most strange is that if you click on the twitter post (not the link) using Twitter app you can see the player correctly with the preview image and play button on it!

We have been reading all Twitter docs, troubleshooting pages, etc, and we have been unable to solve it. The only thing we have added is the twitter:player:stream and twitter:player:stream:content_type that we have read are important to be detected as a player.

Can anybody tell us why this happens? any solution to solve the ERROR and the post appearance in mobile Twitter feed?
Thanks in advance.
Cheers


#5

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.