Twitter cards: Problem with one image, fine with another


#1

My site, daffadillies.co.uk, is approved for twitter cards, and I run several different sites hosted on that domain, including two webcomics, Fetch and Eunice.

Photo cards seem to work perfectly fine when I link to a Fetch comic, but don’t appear when I link to a Eunice comic. The only difference I see is that when I run the validator tool, Eunice has a warning, “unknown aspect ratio,” while Fetch does not. The only thing that changes is the image URL, and there is no difference between the average aspect ratios of images on the two sites.

Any idea what could be causing this?

Thanks.


#2

I have the same problem. I’m setting http://cdn.shopify.com/s/files/1/0191/0894/products/issue3-1_large.jpeg?v=1352359160 as the twitter:image:src, and I get “Unknown aspect ratio”.

However, the URL works, and as this is an image served through Shopify, and may have variable aspect ratio, I have no way to set this manually. Any help on this?


#3

Hi,

We are facing the same issue. The only image that seems to be working is the sample kitten image. We have even tried uploading the kitten image on our server - and we still get the error, “unknown aspect ratio”.

Any help would be great.

Thanks.


#4

Same problem here.

Using Amazon cloudfront CDN triggers the error.


#5

SAme issue we are facing


#6

Me too!


#7

You guys are still lucky. I cannot even validate my site.


#8

Hahaha :slight_smile:


#9

For some reason, I decided to retry the URL I mentioned above after a few days, and the issue didn’t exist anymore. It might be worth keep trying.


#10

I couldn’t get my cards to validate until I added a robots.txt for the site. Now some do and some don’t. Strange.


#11

Same experience here. I get the “Unknown aspect ratio” error message from the validator for the vast majority of image URLs I try. Any additional information from Twitter on this would be greatly appreciated.


#12

There are a couple of things to check when receiving this message. First, make sure that you meet the minimum size requirements (meaning width and height) for an image in the specific card type you are using. Second, if you are using a card that has width and height meta tags, make sure that the value is just the number, i.e., doesn’t include “px.” If the problem persists, please feel free to open a new topic for your specific case.


#13

Okay - specifically I am trying a gallery - so you can’t specify width and height. I am using this image:

so it is coming from amazon. The size is 7.23 KB so it’s definitely under a meg. I can’t see anywhere in the documentation that specifies a minimum or maximum pixel size but this is 200x200 - the first placeholder kitten example is also this size, so I don’t think it’s an issue.

Any ideas?


#14

Same issue here - image URL is a legit image, 200px x 200px. Specified height and width with just the numeric values.


#15

Could you provide an example URL to render the card?


#16

Could you provide an example URL to render the card?


#17

hey jon

We get the same issue, eg. http://galentines-day.com/freegreetings_page.php?subcmd=freegreetings&id=1

can you have a look–we put the height and width. but for example if we replace the og:image with this (to test) it works fine


#18

Hi John receiving the error as well for our gallery views - http://forums.stashedboxes.com/thread/j-1-x-nike-sb-let-the-hype-begin/190839/


#19

I’m getting the same error - gallery card, various sizes of images, simple filenames (e.g. 1.jpg) no query strings, no CDN, just plain old images on a plain old server.

Actually, I’m good - was missing the :src after my images.


#20

I’m getting the same at http://www.slc.edu/explore/map/45-wrexham.html

My images are served via SlideShowPro (http://slideshowpro.net/products/slideshowpro_director/), which serves them correctly regarding MIME type etc.