Twitter Cards not working - "details" link missing


#1

As the title says our twitter cards are not showing up. I know that this problem isn’t that rare but I tried to figure this out by myself, without success. The weird thing is that they showed up before but since the last 2 weeks (or so, wasn’t paying attention) they are not working.

Example:
Here’s the link to a tweet: https://twitter.com/feine_Matratzen/status/600181024702603265
And the correspondending URL: http://feine-matratzen.de/tonnentaschenfederkern-matratze-diamant-7-zonen.html

In the Card-Validator everything works fine but as you can see not in twitter itself.

I hope somebody can help me here.
Thanks and greetings
feine-matratzen


Twitter card works in the validator but not in the tweets
#2

According to the validator I’m seeing:

ERROR: Required meta tag missing (twitter:description)


#3

Thanks for the quick answer,
and yes I saw that too but it was working before e.g the description wasn’t necessary for the cards to work. I also should have picked a better example.

Tweet from yesterday: https://twitter.com/feine_Matratzen/status/600003364408037376
Correspondending URL: http://feine-matratzen.de/set-vital-basic-matratze-lattenrost-42-leisten-fix.html

0 errors in the Validator

Greetings
feine-matratzen


#4

Now I’m confused.
I just realized that the cards are working on our connected facebook Account.
Tweet on Twitter: https://twitter.com/feine_Matratzen/status/600003364408037376
Same tweet on Facebook: https://de-de.facebook.com/feinematratzen/posts/361156190748293


#5

Hi @andypiper @feine_Matratzen
Same problem here, any new?
Thanks!

Tweet: https://twitter.com/GaritoCafeClub/status/600989697234608128
Card Validator:
INFO: Page fetched successfully
INFO: 19 metatags were found
INFO: twitter:card = summary_large_image tag found
INFO: Card loaded successfully


#6

The Twitter card appears for me although it’s missing the image. Your image URL has spaces that are not encoded so I wonder if that is causing the image to not appear.


#7

Same problem. Occurs on multiple sites across multiple servers but here’s one example from a dummy install.

Tweet: https://twitter.com/timcindyn/status/601173139930947584
URL: http://www.designsbyangi.com/template/shop/test/
Validator:
INFO: Page fetched successfully
INFO: 16 metatags were found
INFO: twitter:card = product tag found
INFO: Card loaded successfully


#8

Facebook uses the og: OpenGraph tags, Twitter Cards use the twitter: tags and fallback to the og: tags when they are not present.

Could you try a summary_large_image card instead and see whether that works?


#9

I will try it as soon as I can. I don’t have acces to our Webserver at the moment and our Webmaster is on vacation. He’ll be back on Tuesday. But maybe someone else with the same problem can try this and give us feedback.

Thanks andypiper
Greetings feine-matratzen


#10

@andypiper - Summary_large_image works from the limited testing I’ve done.

Same URL as above but with a summary_large_image card : https://twitter.com/timcindyn/status/601429887124025345

(Edited to add that Twitter updates cards so the information may not appear as I have reset it to a product card)

Here’s a summary_large_image from the same domain.
Tweet: https://twitter.com/timcindyn/status/601431461472833536
URL: http://www.designsbyangi.com/template/template-sticky/


#11

It works now! though I haven’t changed anything.
@andypiper Did you guys “fixed” it?

Anyway big thanks!
Greetings feine-matratzen


#12

Hi @amboutwe,

Thank you for your comment, I have tried without spaces in the name but the problem persist: https://twitter.com/GaritoCafeClub/status/601432837233979392

And it’s a summary_large_image.

Any advance @andypiper?

Thank you very much and have a good weekend :smile:


#13

My dummy site, as well as other sites I’ve tested, are all working, too.

@andypiper Was this something that was actually fixed? Just curious if I didn’t allow enough time in case I need to troubleshoot a similar issue in the future.


#14

@GaritoCafeClub The image shows up when I tweet a “new” URL by adding a ?id=somethingnew to your current URL. From my understanding, this means the cache hasn’t updated.

Tweet: https://twitter.com/timcindyn/status/601806311865462784


#15

Hi @amboutwe!
Thank you very much for taking the time to answer my question.

I’ve tried adding the ?id (http://garitocafe.com/es/articulo/dika_sour_free?id=imfree), but I can’t get it to work.

Tweet: https://twitter.com/GaritoCafeClub/status/602834860911235072

Any ideas @andypiper?

Thanks!

Aleix


#16

The only difference I see between this link and the one I tested is that unencoded space in the image URL. A Twitter staff member, @romainhuet, implies that spaces should be encoded or removed here.