Twitter Cards not appearing


I just got approval for my domain, and made a tweet half an hour ago.

clickity (won’t let me post link directly, slight bug in the forum software there :stuck_out_tongue: It sees all the links in the preview as additional links and easily hits the “new users can’t post more than 2 links” threshold ;))

It’s not showing the card. Have I done something wrong?


It has been over 24 hours and cards are still not appearing. Here is a more recent Tweet that shows no card.


It’s been almost a week now. No replies. This doesn’t exactly inspire confidence, you know…


Apologies for the extended delay in responding to you here - I see you also posted over on Stack Overflow. A lot of the @TwitterDev team took time out during December!

This is odd - initially I thought it might have been because you are sharing a shortened link, and we have had issues with those in the validator recently. We’re in the process for getting a fix for that rolled out. I’ve tried tweeting the unshortened link too though, and that also is not showing any card. I’m going to ask someone to take a look at this as I’m not able to debug further at the moment.


Hi @andypiper, sorry for my frustration! And yes indeed, you found me on StackOverflow XD

I can understand December being a busy time - in my case, it was busy trying to get things to work so I could release a bunch of New Year’s features :wink: Anyway, thank you for taking a look at this, and I hope this can be resolved :slight_smile:


Good day Respected…
I am new to both twitter and twitter cards… When i validate my photo card, it is posted successfully in tweets as can be seen here: but when i change the image url in meta tags, they are not changed dynamically unless i re validate them. What i want is a dynamic image for twitter cards.
please help me out…

Cards images not changing

This question is not relevant to this thread so I’ve started a new one to address your issue.


@SystemSalamence, I spent some time debugging your Product Card and I’ve narrowed it down to your image.

What you have implemented:

I am not sure the exact reason, but it is probably because does not return a valid robots.txt file

The short URL ultimately resolves to, which does have a robots.txt. If you can modify your image URL to use the full URL like below it will work:

That might be your easiest solution. I have tested your meta data with the full image URL and it does work.


@joncipriano I’ve added a robots.txt file to, will that work too?


I see the robots.txt file, but it does not seem to help. This leads me to believe the the Twitter server is just not following the short URL 302 redirect for the image.

You can try switching to a 301 redirect if you are able to, however I’m not 100% sure that will fix it. Using the full URL is going to be your best solution.


All right, I have changed the imale url. Has that worked?


Your Product Card looks to be working great with this URL:

I like your use case for the product card, btw.


Awesome, thanks very much for your help with this.

closed #14