Twitter Cards: keep receiving same error message saying 'warn: no meta tags found', even though correct meta tags are applied

cards

#1

URL in question www.kiteprint.com

This is a shopify website, and I have tried two alternate methods which still will not allow me to validate my Twitter Cards.

  1. Manually adding a ‘liquid snippet’ file which lists the appropriate meta tags.

  2. Using a Shopify Twitter Card App which displays the following meta tags once generated…

Example Product Page to view page source and check meta

I simply get the error message ‘warn: no meta tags found’

Any help on this one would be greatly appreciated!

Thanks,


#2

For whatever reason, when I connect to https://kiteprint.com/collections/frontpage/products/stephen-hawkings-time-travellers-invitation-open-edition and set my user-agent to Twitterbot, it returns an HTTP 404 Not Found error (even though it works fine with a browser and the tags are visible).

See our FAQ and our Troubleshooting guide, but I think you’ll need to find out why your site is not serving content correctly to Twitterbot.


#3

Thanks Andy,

Through doing some further research, I have found it is a known Shopify issue that their developers are currently looking into.