Twitter Cards are working except for lack of analytics

cards
analytics

#1

I have had a problem with Twitter Cards for most of November. Cards are set up for my organization’s website (https://www.newsecuritybeat.org/) using the following source code:

meta name=“twitter:card” content=“summary” /
meta name=“twitter:site” content="@NewSecurityBeat" /
meta name=“twitter:creator” content="@NewSecurityBeat" /
meta name=“twitter:url” content=“https://www.newsecuritybeat.org” /
meta name=“twitter:title” content=“New Security Beat” /
meta name=“twitter:description” content=“The blog of the Wilson Center\'s Environmental Change and Security Program with contributions from the Maternal Health Initiative and China Environment Forum” /
meta name=“twitter:image” content=“https://www.newsecuritybeat.org/wp-content/uploads/2014/06/ecsp-logo-twittercard-435x375.png” /

When people put our URL into Tweets, the Card loads as it should. The Card Validator (https://cards-dev.twitter.com/validator) also checks out.

The problem is that when I go to check the analytics from the cards, there is no data starting in early November. The analytics appeared to work fine before then. This does not seem to coincide with any updates to our site.

Any insights or suggestions would be appreciated!


#2

I am having the same issue. Were you able to resolve it?


#3

same issue here. is anyone from twitter able to respond here?


#4

As far as I know Twitter hasn’t acknowledged this issue… Here’s their only response so far:

It is likely that there are insufficient impressions or an insufficiently diverse range of impressions to provide data - the platform needs to have enough data to anonymise the results to a sufficient level before making that available.

According to Twitter, my cards received > 850K views in October, pretty sure that does not quality as “insufficient impressions”.


#5

This has been the issue for our site as well; at Rewire we went from 4.5 million impressions in October, about average for us, to 600K in November, with no updates at all since November 4. We have had Twitter cards installed for the last year and the cards are actually appearing correctly in Twitter — here’s a typical log for one of our links from Twitter’s validator:

INFO: Page fetched successfully
INFO: 24 metatags were found
INFO: twitter:card = summary_large_image tag found
INFO: Card loaded successfully


#6

I’ve raised these reports internally and I’m waiting to hear whether this is a known issue or specific to individual sites.


#7

thanks @andypiper


#8

If it’s relevant to your troubleshooting, we use a WordPress plugin to generate the Card code on each page of our site: Twitter Cards Meta By WPDeveloper.net

I’m curious if the others having this problem use the same WordPress plugin.

CC:
@hypno_training
@ArkansasOnline


#9

Thanks, all. Please let us know if you hear more from Twitter. I am certain it’s not an issue of insufficient impressions for us either. We don’t use that WordPress plugin, so it’s probably not tied to that.


#10

I’m out of the office for a couple of days but I’ll continue to see what I can learn internally and share back here once I have an update.


#11

Same issue. Subscribing.


#12

I am experiencing this as well. Subscribing.


#13

Hi guys I am with the same issue since November 4th


#14

Please, it would be really helpful!!


#15

Still not working for me!


#16

Still down for us too and would appreciate any update/possible fix. Thanks!


#17

@andypiper have you made any progress on this?


#18

As of yesterday, Twitter cards seem to have disappeared from the analytics entirely.


#19

Posting to make sure this topic isn’t closed. Has anyone heard any news about this? Is Twitter deprecating Twitter Cards Analytics? @andypiper


#20

Our Twitter cards link has also disappeared entirely from the analytics page. Would be helpful to know if this feature is being discontinued or if a fix is likely at some point.