Twitter card


#1

I can’t get the card to validate
this is the error I am getting
FetchError:exceeded 4.seconds to Portal.Pink-constructor-safecore while waiting for a response for the request, including retries (if applicable) (Card error)

I am using WP seo by yoast to create card
please help


#2

Can you please post the URL you tried it with, so we can check it?


#3

http://techmarket.ca/technology-jobs-canada-the-way-forward/

or
http://techmarket.ca

or
http://techmarket.ca/blog/


#4

what does this mean
ERROR: FetchError:exceeded 4.seconds to Portal.Pink-constructor-safecore while waiting for a response for the request, including retries (if applicable) (Card error

Also I called my host and there is nothing being blocked on their end, what is causing this?


#5

This error means that your server takes too long to send a response. I just tried it with curl and it actually takes quite a long time:

    time_namelookup:  1,526
       time_connect:  1,770
    time_appconnect:  0,000
   time_pretransfer:  1,770
      time_redirect:  0,000
 time_starttransfer:  5,502
                    ----------
         time_total:  6,235

After trying it several times, I was able to get a card preview to work, so it seems it’s set up correctly but your server is just very slow sometimes.
You might want to look into some caching plugins or Varnish caching proxy to get a faster response time. Ideally it should be less than 2 seconds.


#6

This is from my hosting provider

Hi Mark,

I’ve been doing testing and every time I do from multiple location (including off site) I’m getting sub 2 second total times (using the same test he is) so I’m not sure what’s going on from his end. It seems fine to me. Are you still getting errors?

Nick D.
Canhost.ca


#7

We are all working hard to figure out what the problem is.

My contact Nick at Can host, nick@canhost.ca can figure out what the problem is. He is getting less that 2 second response times. The problem is on your end.


#8

ok we got it working but now the cards are still not showing when I tweet

What is wrong?


#9

It seems to work fine now:


You just have to send a whitelist request.


#10

yes it is now

thanks
how do i change images


#11

What do you mean by changing images? A Twitter summary Card can only have one image as far as I know.


#12

You can specify an image URL in your cards markup.

Once you’ve done that and your site is whitelisted, the image will be part of the card (summary, photo etc).

The Twitterbot cards crawler caches the image for up to about 7 days, so even if you change the image, it may not initially be reflected in the card until the re-crawl occurs for that URL. Check the Cards Troubleshooting guide for more info on this.