Twitter card wont validate - no metatags found


#1

Went through the getting started guide and when I go to validate my page I get the error “no metatags found”.

An example page is:

I added the twitter:site/twitter:card tag and then I have the other og: fallback tags to provide the rest.

Also tried curl -A Twitterbot with that link and I see all my meta tags.

Any ideas? Thanks


#2

If I pull the page using curl, I’m not seeing the tags rendered in the correct places. Is there Javascript code that is rendering the tags on page load? That will not work as our card crawler cannot execute Javascript.

Lots of troubleshooting information in our pinned post.


#3

Yes though each page is rendered server side. Is it possible we have that one react-props tag that is massive and twitter stops parsing due to that?


#4

Yes, possibly. I’m not seeing a rendered valid card tag in the header when I pull using curl though.


#5

Really? I just made some changes so the header tags are reorganized at the top instead of after that one huge meta tag. Still no luck though. When I use curl I’m seeing all the appropriate tags based on the guidelines. Also other sites seem to be ok processing the meta tags when I link our pages.


#6

Here are the ones I see right at the top:

<meta name="twitter:site" content="@MassRoots">
<meta name="description" content="some description">
<meta name="twitter:card" content="summary_large_image">
<meta property="og:type" content="article">
<meta property="og:description" content="some description">
<meta property="og:title" content="Four Crucial Marijuana Hearings This Week | MassRoots">
<meta property="og:image" content="some image">

#7

Your server is not returning a Content-Type header, so the cards crawler is unable to parse the response.


#8

Added that. Still nothing :frowning:

<meta http-equiv="Content-Type" content="text/html;charset=UTF-8">

Is it supposed to be:

<meta name="Content-Type" content="text/html; charset=UTF-8" />

Or is this something I need to configure on the server?


#9

It’s a webserver thing, not a file content thing.


#10

Hey Andy,

I added the Content-Type. Set it to: text/html; charset=utf-8

Still getting same error.


#11

Nevermind its working! Thanks for all the help! Setting response in header to text/html; charset=utf-8 did it!!!


#12