Twitter Card Stopped Working


#1

Hi,

Twitter Card was working fine on my website www.shaanhaider.com since long but suddenly it stopped working since last few days and the Validator is showing the error “Not Whitelisted”.

Need some help to solve this issue.

Thanks


#2

Moving this to the Cards category as this question is not Fabric specific.


#3

There is no twitter:card markup in your page, so if this was working before, something must have changed in your site. Please review the troubleshooting post.


#4

Thanks for the reply Andy… I am gonna check what’s wrong based on the troubleshooting tips and will update again here.


#5

Hi Andy,

Checked the code of my website and found that the twitter:card markup code is still there. The code is as below. Please, let me know if there is anything wrong with it

<b:if cond='data:blog.pageType == &quot;item&quot;'>
      <b:if cond='data:blog.postImageUrl'>
        <b:if cond='data:blog.metaDescription'>
          <meta content='summary_large_image' name='twitter:card'/>
          <meta content='@shaanhaider' name='twitter:site'/>
          <meta content='@shaanhaider' name='twitter:creator'/>
          <meta expr:content='data:blog.pageName' name='twitter:title'/>
          <meta expr:content='data:blog.metaDescription' name='twitter:description'/>
          <meta expr:content='data:blog.postImageUrl' name='twitter:image:src'/>
          <meta expr:content='data:blog.homepageUrl' name='twitter:domain'/>
        </b:if>
      </b:if>
</b:if>

#6

Latest update - Card started working by itself without making any changes. Do not know what was wrong but seems it was from Twitter side as I took no step to fix it. Good thing that it is working fine now.

Thanks for all the help and support.:slight_smile: