Twitter Card not working

cards

#1

Hi everyone. Strange thing here.

One community, two blog posts. Virtually identical metadata, but one doesn’t render properly when posting to Twitter.

Using the Card validator:
https://community.spotify.com/t5/Spotify-Community-Blog/The-Tip-Off-PAUW/ba-p/1482837
INFO: Page fetched successfully
INFO: 15 metatags were found
WARN: Not whitelisted
https://community.spotify.com/t5/Spotify-Community-Blog/The-Tip-Off-Mega-Ran/ba-p/1423394
INFO: Page fetched successfully
INFO: 20 metatags were found
INFO: twitter:card = summary_large_image tag found
INFO: Card loaded successfully

Link to metadata comparison shared in txt file

Screenshot of the issue:


Ironically, I just noticed that pasting the “broken” url in here makes the card display properly:


#2

The first of the two links has no twitter:card type in the markup, so the validator is unable to render one. Check the troubleshooting FAQ post for more things to check when diagnosing issues like this.


#3

Hey there. They both have
<meta name="twitter:card" content="summary_large_image"/>

Is there another twitter card tag missing?


#4

I don’t see that in the first page, sorry. Actually I don’t find any twitter: tags there.


#5

Are we looking at the same page?


#6

Super weird - I just don’t see that same markup in the page. I’ve tried both in my browser, and by fetching it using curl -A Twitterbot.

Is there a CDN that could have externally cached something different? could this not have been fully deployed to the server? I’m surprised that we are seeing different things.


#7

Now I see.

I was thrown off by the fact that one url worked and one didn’t, even though their path is virtually identical, so I never thought to check.
The code doesn’t seem to render for all unauthenticated users. This indicates to me that it’s an issue with our platform vendor.

Thanks for the help!


closed #8

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.