Twitter Card not showing, please help!


#11

your card is working fine, and shows up in the Tweet detail view as expected.


#12

Your site looks good - the top level URL has no card attached, but individual posts are using summary_large_image cards and should work fine. Here’s an example Tweet with your most recent fireworks post attached - https://twitter.com/evilpiper/status/621242942053818368


#13

Hi, hope you don’t mind me adding here, but I have the same issue.

There are various tweet buttons (homepage) but when I tweet, there is no “view summary” and no card. It was working until yesterday when I turned off the card output (via Yoast plugin), but since I reenabled and adjusted the text output with the Tweet, it stopped working.

This is the site/page: http://saveafricanhistory.handsupstaging.com/

Been testing it here: https://twitter.com/reflexlabtest

Thanks


#14

Hi, Andy!

Same for me as well, I think I have the write code inside my Tumblr HTML, and I am using a custom domain instead of name.tumblr.com with my Tumblr account. I could swear it was working in the past, and validator seems to be working OK, but no dice on Twitter Details page, and in the new Timeline view as well.


http://nerdcast.org/post/124208649067/marvel-knights-4-4


#15

Hi Andy,

Thanks. How do I get my top level URL card attached and not just individual posts?


#16

Same thing here. The Card validator is displaying my summary card correctly, however, when I actually share it through a “share button” it does not display a twitter card on my timeline, it only shows a regular tweet.


#17

What is the link with your card, and can you provide an example Tweet?

Lots of useful information in our troubleshooting page and post.


#18

Thanks for trying to help. I can’t figure out what the issue is and I can’t find usefull help anywhere. These things shouldn’t be so complicated. The site is still at an early development stage but this is the link: http://louzanimales.pt/teste/caes-para-adopcao/01.htm


#19

I just Tweeted your link and the card shows up fine. Cards only show in Twitter’s own mobile apps and web app, and not in the Tweet intent or web Tweet composer windows.


#20

Well I just tweeted it and I went to my twitter account profile to see how it looked like and it shows no Title, no Description, no Image and no Linking to the page I want to share. I copyed the link for the tweet, see for yourself: https://twitter.com/davidxmartins/status/806170177171783680


#21

Agreed that I can’t see a card or a URL in that Tweet. How are you posting your Tweets.?

Here’s a link to the Tweet I posted earlier, which worked. https://twitter.com/evilpiper/status/806136692147126273


#22

Not sure what you mean regarding how am I posting my tweet. I’m just clicking the “Share on twitter” button you see on this page http://louzanimales.pt/teste/caes-para-adopcao/01.htm and then I click the “Tweet” button on the new window. On the link you provided to the tweet you shared everything looks exactly as expected. So why is it that when I do it it looks like this: https://twitter.com/davidxmartins/status/806303956909559808


#23

OK this is the issue. The code for that button is not a regular Twitter share button - it uses an outdated Twitter logo, and when I click it the result is https://twitter.com/intent/tweet?text=Testing%20Testing%20Testing which does not include the URL or web link you are trying to share. You need the web link to be shared in the body of the Tweet in order for the card to work.


#24

Thanks again Andy. What you’re saying makes sense to me, however I’m merely using the coding suggested by this page https://dev.twitter.com/web/tweet-button and I can’t find any help there as to how or where I should include such link. Could you please provide an example of a properly coded twitter share button so I can see how I should do it?


#25

You need to include the URL in the text parameter for your web intent.


#26

So, instead of https://twitter.com/intent/tweet?text=Testing
I should use https://twitter.com/intent/tweet?text=http://louzanimales.pt/teste/caes-para-adopcao/01.htm
?


#27

Yes, something like that - you might need to URL encode the value.


#28

I tryed replaycing “testing” with my page URL encoded, like this:
href="https://twitter.com/intent/tweet?text=http%3A%2F%2Flouzanimales.pt%2Fteste%2Fcaes-para-adopcao%2F01.htm

However, All I can see is a regular tweet with my page address on it instead of “Testing…”


#29

Could someone please show me an example of a functioning share button preferably with a summary large image?


#30

After so many vague replies, here’s what I found out:

  1. First off, keep in mind that the card only shows in the final posted Tweet - not in the Tweet composer window. However, in my case, it wasn’t showing in the final posted tweet either.

  2. You have to include the link to the page you want to share after the text parameter. Additionally you need to encode its URL value. So, instead of text=http://example.com use text=http%3A%2F%2Fexample.com. If you go to http://www.w3schools.com/tags/ref_urlencode.asp you can make this encoding convertion automaticaly.

  3. I’ve been told that sometimes there is a delay as twitter’s crawler caches your site, which would explain why the card doesn’t show in the final posted tweet in your fist attempts to share it. In my case it took 48 hours, after which, clicking the share button will post the card immediately.

Hope this may be helpful to someone else.