Twitter card not showing image after website migration

cards
images

#1

Hello, I’ve read as many related issues as I can and I still don’t know why my images aren’t showing up. It is happening for all of my Wordpress posts where they used to show images. It most likely has something to do with my recent server migration–I suspect I inadvertently locked down a port that is preventing Twitterbot, but I can’t find any info on that now.

Here’s my card data:

<meta name=“twitter:card” content=“summary_large_image”>
<meta name=“twitter:site” content="@marcysutton">
<meta name=“twitter:title” content=“Writing winning abstracts”>
<meta name=“twitter:description” content=“The description”>
<meta name=“twitter:image” content=“https://marcysutton.com/wp-content/uploads/2017/04/Excited-1.jpg”>

Here’s my robots.txt file:

User-agent: *
Disallow: /music/
Disallow: /opentape/
Disallow: /wp-content/
Disallow: /wp-includes/

I can reach the twitter:image URL and it has the correct permissions. I’m wondering if there’s a port I can check as well? Here’s the page in question, which is reachable with CURL. Here’s an example: https://marcysutton.com/writing-winning-talk-abstracts/

Thanks so much.
Marcy Sutton


#2

D’oh! I just noticed I was disallowing wp-content, so I’ve updated robots.txt:

User-agent: Twitterbot
Disallow: *

Allow: /images
Allow: /wp-content/uploads/

Hopefully that works. If it doesn’t, I’ll reply back since I couldn’t find a way to delete this post.


#3

I believe it works “downwards” ie you are explicitly disallowing all robots on all locations. You need to enable Twitterbot to see images before denying everything above that.


#4

Oh thanks. I didn’t think it mattered after reading Google’s specification but I went ahead and changed it. How long does Twitter cache that file–I read 24 hours, is that accurate?

One thing I don’t understand is why it worked at all before. I migrated the same exact files to a new server, which is why I think it might be related to a port.


#5

Generally we cache for 7 days for cards. I’m still seeing the previous version of the robots.txt file which starts out disallowing Twitterbot from everything.


#6

I updated it last night and it magically started working–so the cache is obviously less than 24 hours, or it was caused by something else. Who knows. It’s fixed now, thanks so much for your help!


#7

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.