Twitter card image not displayed


#1

Issue: Twitter card image not displayed when tweeting the link & using the validator tool the image does not show up but there are no errors displayed.

Example URL: https://sharespace.digital/discussion/313

Troubleshooting steps tried already:

I have been through all the steps in the above article

curl -A Twitterbot https://sharespace.digital/discussion/313 > page.html shows the following metatags

<meta property="og:title" content="What Department is best suited to handle Drop-shipment MIGO's? - socialspace">
<meta property="og:description" content="Hello - I am wondering if someone can please share how they handle MIGO (Goods Receipt) for Drop-Shipment Orders. Our business model include scenarios...">
<meta property="og:image" content="https://sharespace.digital/images/twitter_sharespace_discussions.61019b50.png">
<meta name="twitter:card" content="summary">

I can get the referenced image fine with curl -A Twitterbot https://sharespace.digital/images/twitter_sharespace_discussions.61019b50.png > image.png

I don’t think there’s a problem with robots.txt as we have:

User-agent: Twitterbot
Allow: /

And images show up fine when tweeting other areas of the site eg. https://sharespace.digital/blog/5-ways-drive-e-invoicing-compliance - the images for other parts of the site are stored in a different location but should be an issue as Twitterbot is not blocked anywhere.


#2

Just checked and the image appears to be working ok. Are you still experiencing issues?


#3

Hi Andy, yes it seems to be working now. I did retry it again a week or so ago and no joy, I’m not sure why it’s suddenly started working now since neither the image path or metatags have been changed since I made the post.

Thanks for checking!


#4

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.