Twitter Card Image not Displayed Anymore


#1

Twitter Card validator shows no issues, but the image is not loaded for the posts on our site.
I did recently change the cache plugin for my site, would that interfere?

URL affected (must be public):

I added Allow: /images/* to robots.txt, but no visible changes.


#2

Your page contains

  <meta name="twitter:title" content="Is Your TSFA Ripe for an Audit" />
  <meta name="twitter:card" content="summary_large_image" />
  <meta name="twitter:description" content="A recent BMO survey revealed that Canadians contributed about $1000 less to their TFSAs in 2016 than they did the &amp;hellip;" />
  <meta name="twitter:image" content="https://lsminsurance.ca/images/tfsa-audit.jpg" />
  <meta name="twitter:url" content="https://lsminsurance.ca/life-insurance-canada/2017/11/is-your-tsfa-ripe-for-an-audit" />
      <meta name="twitter:creator" content="@LSMinsurance" />
        <meta name="twitter:site" content="@LSMinsurance" />
<meta name="twitter:text:title" content="Is Your TSFA Ripe for an Audit" />
<meta name="twitter:image" content="/images/tfsa-audit.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />

The second of the twitter:image references is a relative path. This is not supported. The crawler cannot find your image as a result. Please review the troubleshooting post. You should also eliminate the other duplicated and invalid tags.


#3

Perfect thanks. I didn’t realize a plugin had added these extra tags.


#4

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.