Twitter card error with Yoast, validator Unable to render Card preview


#1

Hi there,
I just set up the Twitter card option via Yoast in my WP website, http://invitadoinvierno.com/, and I get the message Unable to render card preview with this log:

INFO: Page fetched successfully
INFO: 6 metatags were found
ERROR: No card found (Card error)

I’ve checked the source code of the page and the tags seem to be there. I’ve also checked previous forum discussions on similar issues, but none seem to make things a few clearer for me.

I would really appreciate some insights on this. Thanks!


#2

I don’t know what is going on exactly here, but I can fetch your site using Chrome, click through to a post like http://invitadoinvierno.com/postres-reposteria/bizcocho-de-mandarina/ and view source, and I see the Yoast plugin markup and twitter:card tags.

However, when I load the page from the command-line using curl, I see an entirely different set of markup on that page (it refers to All in One SEO Pack 2.2.3.1). It looks like something odd is going on.


#3

Thank you Andy for taking a look at it.

Hmmm, I see. I just changed to the Yoast plugin a few hours ago, I previously had All in one SEO installed. Maybe the plugin didn’t clean up after itself or it has something to do with the caché?

Best,


#4

Those are both possibilities, unfortunately I am not able to help with a detailed debug of your Wordpress installation :smile: hope you can figure it out.


#5

Thank you Andy, it did have something to do with the caché, because it has solved on its own. I can now preview the card and apply for being whitelisted. I was being a bit impatient.

Best,


#7