Twitter Card Error: Internal Server Error


#1

Hi there.

I’m trying to validate the following page as a Twitter card

However it keeps coming back with

Error: Internal Server error

Any ideas? Thanks so much


#2

Certainly not a helpful message. Will get back to team on that.

That said, do you know if you have any IP restrictions in place, either yourself or your host provider?

Here’s a troubleshooting page with common issues worth checking out:

https://dev.twitter.com/cards/troubleshooting


#3

Thanks so much for the reply. Nope - we checked and asked hosting to check also…

Any help you can give would be greatly appreciated.


#4

What is your hosting provider?

Lets wait to hear back from them. It may help to give them the ASNUM from the troubleshooting page I sent earlier, and the IP list.


#5

Hi - I have done and they say there is nothing their end to block it.

I also set up Twitter cards for www.silentdirector.com which is on the same server and no issues what so ever?


#6

Any thoughts @rchoi ?


#7

Same issue posted on stackoverflow:


#8

Any thoughts? What can we do to resolve?


#9

HI - any thoughts? Still can’t get this to happen…


#10

I am having the same problem.


#11

I’m having the same problem too for the past week.


#12

Same problem here.
And we’ve checked the access logs, which contains the request from Twitter and 200 response.


#13

I checked with my server and got this response:Hello,

I’ve cross-verified the issue and was able to replicate the same. However, the back-end permission and configuration is fine for the website. There was a recent report on the the same issue at Twitter cards not working. Validator returns ‘Internal Server Error’ . However, there isn’t any solutions provided for that. You can refer: http://torquemag.io/installing-twitter-cards-wordpress-site/ which says that issue is with Twitter’s Validator itself. Please contact the twitter support regarding this and seek their assistance.


#14

We are having this same issue. We have validated Cards on all our sites and they are all on the same server and they are all subdomains. This is also a subdomain and we have the same setup technically with this site as the others. We are at a loss. Anyone have a fix?


#15

Hello guys! I’m having the same error message when I try to validate a random post of my blog using the validator. I’m not expert at php and tags so I used the auto meta from Yoast. Can anyone help with it? My Blog page is http://vasilenev.com/blog


#16

I cannot see any twitter:card tags in your pages.


#17

Hi, I’m having the same problem too, but the tags appear to be in place. An example page which won’t validate and generates the error is: http://stationaryjourney.com/pilot-capless-fountain-pen-matt-black-review/


#18

Hey I think now I have the codes by JM Plugin and still have the same error code. I will try to find out what to do…


#19

Hello everyone!

An update has been pushed for the validator to hopefully resolve most instances where “ERROR: Internal Server Error” would be returned. Please give it a try and let me know whether or not you are still experiencing issues!


#20

Ok, checking some URLs on here, I’m still seeing the issue myself. Reporting these instances back to the team.