Twitter Card: ERROR: Fetching the page failed because other errors


#1

Issue: Unable to return Twitter card specified. Getting ERROR: Fetching the page failed because other errors.

URL affected: https://rdmap.co and anything within

Troubleshooting steps tried already:

I’ve taken a look at the hostname of server and name on SSL certificate which match. Unless I’m missing something I really can’t see what I’m doing wrong. All meta tags are in as they should be. Please help.


#2

I have the same problem as well.


#3

Same issue here. Cards stopped working about 2 weeks ago. Already tried the troubleshooting steps with no luck.
This is one example: https://writersboon.com/quote/73
Please help.
Thnaks.


#4

Did anybody find an answer for this problem??


#5

This appears to be working today. Do you still have other issues?


#6

You have not shared a URL so it is impossible to help. Have you confirmed that your site has a valid SSL configuration per the troubleshooting FAQ?


#7

There are SSL verification errors with your site, which would explain the problem.


#8

Thank you, but I have not changed the certificate in a long time and the cards stopped working only recently. Did Twitter change anything? Do I need to contact my certificate provider?
Many thanks again.


#9

We have not changed anything. I’m not sure what to suggest to you.


#10

Thank you so much for your help. Can you please send me the error log so I can forward it to the certificate issuer and have the issue resolved by them?
Many thanks again.


#11

The error needs to be resolved by the site host, not by the card issuer. The troubleshooting FAQ post I linked to above describes the SSL issue in detail.

I tested this using this command:
echo -e "HEAD / HTTP/1.0\r\nHost: writersboon.com\r\n\r\n" | openssl s_client -servername writersboon.com -connect writersboon.com:443 -state -quiet

Result:

SSL_connect:before/connect initialization
SSL_connect:SSLv2/v3 write client hello A
SSL_connect:SSLv3 read server hello A
depth=0 OU = Domain Control Validated, OU = EssentialSSL, CN = writersboon.com
verify error:num=20:unable to get local issuer certificate
verify return:1
depth=0 OU = Domain Control Validated, OU = EssentialSSL, CN = writersboon.com
verify error:num=21:unable to verify the first certificate
verify return:1
SSL_connect:SSLv3 read server certificate A
SSL_connect:SSLv3 read server key exchange A
SSL_connect:SSLv3 read server done A
SSL_connect:SSLv3 write client key exchange A
SSL_connect:SSLv3 write change cipher spec A
SSL_connect:SSLv3 write finished A
SSL_connect:SSLv3 flush data
SSL_connect:SSLv3 read server session ticket A
SSL_connect:SSLv3 read finished A
HTTP/1.1 301 Moved Permanently
Date: Mon, 04 Sep 2017 08:42:37 GMT
Server: Apache/2.2.15 (Oracle)
Location: https://writersboon.com/ords/f?p=WB:HOME:0:::::
Vary: Accept-Encoding
Connection: close
Content-Type: text/html; charset=iso-8859-1

SSL3 alert read:warning:close notify
SSL3 alert write:warning:close notify

From the FAQ post:

  • if you see a validator message about Fetching the page failed because other errors or similar, check your SSL configuration. The certificate and server name must match (or be aliased to match) due to Java security constraints. More in this thread.

#12

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.