Twitter Card Error "ERROR: Fetching the page failed because other errors."

error-codes
cards

#21

Thanks Ralph. Glad you got yours working. I will try this on our site.


#22

Im having the same problem, and the log only show minimal info “ERROR: Fetching the page failed because other errors.”. I tried @ralphsnart .htaccess solution, but no success. The Url: https://riskinnovation.asu.edu/ @andypiper can you take a look at the log and give me some more info?

Thanks
Haytham


#23

Make sure you’re not blocking Twitterbot. Add this to the end of robot.txt…

User-agent: Twitterbot
Disallow:

Also, your validating url and image meta url needs to be http and not https.


#24

handshake alert: unrecognized_name at remote address which almost certainly means your web server’s SSL settings are not correct. There are a few threads like this one and this one which refer to ways to resolve SSL issues so that strictly-configured Java-based code can work with them.


#25

thanks @andypiper that helped, I reconfigured my settings and resolved the issue.


#26

SSL was not helpful for me, please check my application heropay.com based on django-python framework.

andypiper please help in this.


#27

I also get handshake alert: unrecognized_name at remote address from an SSL connection to your site, so I believe this is likely to be a similar issue. Your certificate has a wildcard name of subject=/CN=*.heropay.com which is not an exact domain match, per the other threads I linked above, try modifying your ServerName and ServerAlias appropriately.

Also, please don’t tag individual members of Twitter Staff for help, since we may be unavailable from time to time.


Unable to render Card preview
#28

andypiper Can you help to check my domain also : https://www.giantsingapore.com.sg/about-us/our-retail-formats/
I recive the same error message,.


#29

Same issue, so I suggest you check the other threads I linked above for ideas to help to resolve the problem with your site or server’s SSL setup.


#30

@andypiper I’ve got the same issue with our web app. Currently there the SSL/HTTPS is disabled. When I copy the input of our crawler-page onto another webserver and serve it as a static file, it works fine.

When I run the card validator there’s no request logged.
The page is running on port 8080. Maybe that’s a reason, don’t know.
The server is listening for a user agent matching /twitterbot/gi and serve the related static crawler-page.


#31

If you’re able to run it without an explicit port I suspect that may help.


#32

@andypiper thanks for the fast reply! works fine :slight_smile:


#33