Twitter Caching Card Results?

website-card

#1

I have confirmed with the Card Validator that my markup is correct and pointing at the correct site but when the link is actually shared on Twitter, the wrong site is being shared. I believe this was from a misconfiguration of the markup previously that may be cached? It’s a long shot but it’s really my only hunch given that the Validator says everything is correct.

Any help or insight would be greatly appreciated.

Site I’m attempting to share: http://www.popcentraltv.com/


#2

I’ve just tried this in the validator and by sharing a Tweet with the link, and in both cases I’m seeing the same result. What is incorrect?

There’s a good chance that this is a 7 day crawler cache issue if there’s something wrong, but at the moment it looks as I’d expect.


#3

Andy, thanks for the reply. I’m attempting to steer your towards a specific tweet that shows the wrong results but the Twitter Forums say I have exceeded my link sharing (I suppose this is an entirely separate bug).

Can you please look at the popcentraltv account for status 759803299943985152 as an example of the incorrect data being shared. Is this the cache issue at work?


#4

Yes, it seems to be. I re-ran that URL in the validator and it gave me the same incorrect card at first, and then I added something junk to the end (?s=wibble seemed to do it!) and the validator gave me the correct image. I think that Tweet may resolve itself now.


#5

Phenomenal. Thank you.

Any insight on how I can fix this myself in the future? Just add gibberish query param?


#6

That can help to flush the cache per the troubleshooting guide, but it varies per server platform. Seems to have done this trick this time.


#7