Twitter buttons do not work, not the counting the actual buttons in 4 browsers at least


#1

The twitter buttons are not working for me, and everyone says that they work for all browsers it is just not true. Whenever I post on twitter no one gives me a answer I can get something from and I am at my wits end now. The twitter buttons are not working in Chrome, Safari, IE8, and firefox. I have uploaded to a server and my javascript in on in the browers, there must be a clue somewhere.

<a href="https://twitter.com/twitterapi" class="twitter-follow-button" data-count="horizontal" data-lang="en">
Follow @twitterapi</a>
<script type="text/javascript"><!/* <![CDATA[ */!function (d, s, id) {var js, fjs = d.getElementsByTagName(s)[0]; if (!d.getElementById(id)) {js = d.createElement(s); js.id = id; js.src = "http://platform.twitter.com/widgets.js";  fjs.parentNode.insertBefore(js, fjs); } }(document, "script", "twitter-wjs"/* ]]> */></script></code>

#2

Hi Christine,

The text inside your script tag there looks to have been modified at some point – we don’t typically return Javascript wrapped in “<!” and “/* <![CDATA” and I’m imagining this is why you’re seeing the problem.

Something closer to this is what you’re looking for:

Follow @twitterapi

#3

Hello episod
Thanks for responding, but I did not originally have the cdata tags. I placed them there in order to get it all to work, as I use XHTML.
With or without the cdata tags the buttons are still not showing.


#4

I just started trying to use Twitter today and I can barely navigate anywhere in the site because the buttons simply do not work. I have tried IE and Firefox and they won’t work in either. A few of the buttons will work occasionally, but then the functionality on the new page is completely flawed. For example, I tried to put in my correct time zone and when I click save a popup box says I have to enter my password to complete changes. Before I can even enter anything it goes away and says I entered an invalid password and no longer provides a save button on the page. Basically the site is useless if it can’t be navigated. Any ideas?


#5