Twitter button publishing shortened urls do not work


#1

On my website twitter button is not working properly: http://www.choosehelp.com/experts/eating-disorders/eating-disorders-william-anderson/i-used-to-have-anorexia-and-obsession-with-diets.-ive-recovered-but-the-paleo-diet-sounds-healthy.-should-i-try-it (at the bottom of the page)

Now there I have 2 issues:

  1. t.co urls shortener doesn’t work
  2. suggestion to follow ‘via’ twitter username doesn’t work, but this concerns ONLY our own user ‘choosehelp’ on twitter, and seems to be working ok with any other username. I made sure that my twitter user wasn’t following ‘choosehelp’ while twitting, but still wasn’t able to get ‘suggestion’ screen working for me (and even tried twittering using a few different accounts).

I’m wondering if the issue is with ‘choosehelp’ username or twitter button API or with my integration?


#2

t.co is still working correctly, but the combination of the page title, the via parameter you’ve added, and the URL after being wrapped with t.co makes for a tweet longer than 140 characters.

“I Used to Have Anorexia and Obsession with Diets. I’ve Recovered but the Paleo Diet Sounds Healthy. Should I Try it?:” is 117 characters.

Your URL is counted as 20 characters at this time – though it displays your whole URL in the box, it’s counting toward only 20 characters.

" via @choosehelp via @choosehelp" counts for 16 characters.

117 + 20 + 16 = 153 characters.


#3

Yes, indeed. URL shortener works fine, I just thought that t.co should appear inside the very first twitter input field.

The left issue is that I can’t make twitter suggestion screen appear for ‘choosehelp’ user. Any hints? As I already mentioned, suggestion screen works fine for any other twitter user, apart from 'choosehelp.

Thank you!


#4

Are you already following @choosehelp? The recommendation dialog will only display if the user being recommended to doesn’t already follow the recommended user.


#5

Nope, I’m not following that user. I even tried creating 2 more new twitter users and experimented with them. Still these new users were not able to see suggestion screen. Only “All done.” message.

Once, I replace ‘via=choosehelp’ with anything else, e.g. ‘via=google’ everything works perfectly. So I guess there is kind of issue with ‘choosehelp’ username.

I remember it was working a few months ago when I just integrated the button on the site. But since some time it stopped working.


#6

Hi Taylor,

Any updates on my issue with ‘choosehelp’ twitter username not working for post-tweet suggestion screen?


#7

www.arekbagus.com


#8