Twitter api problem with firefox, chrome etc


#1

Hi,
It seems like twitter API has some problems regarding the browsers like firefox and chrome. The line below works fine in Internet Explorer and I can bind and display a “Connect with Twitter” button in the div. When it comes to firefox or chrome binding fails and button not displayed.

I have created a page trying to figure out the problem. this page has only a div, nothing else. And I have a .js file with only a single function in it that I call in the “onload” event of the page “body”.

script is below:

function bindConnectButton() {
twttr.anywhere(function (T){
T(’#divToBind’).connectButton();
});
}

this works in IE and Connect with Twitter button is displayed in place of the “divToBind” div.
not working in firefox, chrome, opera.
when I trace the script in firebug it says “T is not defined”.

Can you help me out with this issue please


#2

removed the above function and call to it in “onload” event of the body.
added below lines to the external .js file. nothing changed. works in IE, not others.

$(document).ready(function () {
twttr.anywhere(function (T) {
T(’#divToBind’).connectButton();
});
});

(firefox version is 3.6.20)

edit:
upgraded firefox to 5.0.1 still no luck.
chrome:13.0.782.112
edit2:
same problem applies to “followButton()” as you can imagine.


#3

Hi @serdarosmanonur,

I’ve tested the following snippet of HTML in a number of browsers and have the buttons rendering fine. Can you share a bit more on how your page is structured? How compliant is the remainder of your HTML?

Test

#4

Copied your code into an empty htm document and I am still having the same problem. when I try I just can’t get it to work on firefox or chrome.
have you tried it with current firefox version? I will deploy that code in a htm file and give the link here.


#5

Hi,

I have just tried you link in FF6 and I can see the buttons no problem. Here is a screenshot:-

http://madtogger.co.uk/screenshots/test-buttons.png


#6

Hi @episod,

the ‘Follow’ Button that appears when clicking the link below is exactly what I am after for my own website, where do I find it & the code?

Do I need to have a @Anywhere domain?

Regards…,

MT


#7

could you try the following link and see if you can see the buttons? I don’t know what is goin on but I can not see them using my browsers which are latest firefox, chrome and opera.
Works on IE 8.
http://aspspider.info/serdaroo/

edit: ok, I switched to my old laptop and everything seems to work. even with older versions of firefox.
Seem like problem is specific to my current laptop and/or some settings on it. I will let you know when I figure it out.


#8

@MadTogger,

You are going to need to request “anywhere.js” with a valid ID (please see the page source here: http://aspspider.info/serdaroo/ ). When you click the folow button, it will open up a login page, when you hit “connect” on this page it will try to redirect you to a page specified or by default to the same page. This page has to be authorized by the application that is defined by the “key” (or ID value I have mentioned above) otherwise follow action will fail(you can see how it fails to follow by trying on the page in the link ı just provided). So you will need to get this app key from twitter.


#9

@episod ,
I might have figured it out. It might be about the OS architecture. When you try the above link on 64-bit win7 using browsers such as chrome, firefox, opera the buttons will not load. When you click the link in 32-bit Win 7 using the same browsers the buttons will load.

Could you confirm?
serdar


#10

I’ll introduce this notion to the engineering team and we’ll go from there. Thanks for all the details!


#11

So you have confirmed the problem?
I will be looking forward to hear from you guys about this problem.

thanks.
serdar


#12

I don’t have the environmental necessities to personally confirm the problem but we’ll look into it. Have you considered using Web Intents or the Follow Button instead of @Anywhere?


#13

I need @Anywhere to let the visitors login and tweet thru my app if they want to.


#14

@episode,
Have you had any chance to dig into this issue yet?


#15

@episod,
So, you have not?


#16

Still waiting on this :frowning:


#17

The bug is filed but I have no ETA for a fix. I will ask the engineers and developers to prioritize.


#18

I believe It should be quite important for you guys too.

Thanks.


#19

update:

Tried with firefox 6.0.2. still the same problem. If you try to navigate to this page http://aspspider.info/serdaroo/ you can see the buttons loading in 32-bit win 7, but they are not loaded in 64-bit win 7.

In firebug it says “ReferenceError: T is not defined” for the line “twttr.anywhere(function (T) { …” while T is defied with all the functions like signIn(), User(), one() etc. when debugged on Internet Explorer 9.


#20

Seems like issue is fixed and seems it was fixed by making some part of twitter API go SSL. And that was what I was suspicious about anyway.