Twitter API exchanging 2 accounts


#1

I have 2 twitter accounts, the first one is my personal, the second one is this, my company twitter @LeanSurvey.
Ok, I tried to use @LeanSurvey tweets on my website(http://leansurvey.com.br), so I installed the App on THIS twitter account, got the Customer Key, Customer Secret, Access Token and Access Token Secret for THIS ACCOUNT and used on the website. Result, the website is showing my personal account tweets. I’m not logged in on that twitter, I tried a different browser for that, and I don’t have ANY APP on the dev.twitter.com on that account.

I don’t know what is happening, but please, could someone help me out?


#2

Hi,

Can you explain more what API endpoint and the request you are doing to the API? I’m asking this because you can show any user timeline from this App you created, given that all timelines are public.

Are you trying to embed a timeline in your website? You can also use Embedded Timelines instead of building an API integration.


#3

Hi lfcipriani, thanks for the fast response

I have a WordPress website with a theme that is integrated with twitter API, so to use the twitter timeline on the widged, they ask for theses simple steps:

  1. Go to "https://dev.twitter.com/apps," login with your twitter account and click “Create a new application”.
  2. Fill out the required fields, accept the rules of the road, and then click on the “Create your Twitter application” button. You will not need a callback URL for this app, so feel free to leave it blank.
  3. Once the app has been created, click the “Create my access token” button.
  4. You are done! You will need the following data later on:

Then they ask for:

Customer Key
Customer Secret
Access Token
Access Token Secret

So I followed all the steps.

I don’t have experience with CSS, HTML or anything like that, I bought the WordPress Theme because of that, don’t need to code at all.

The issue is, it is showing my other account (@salaroli_) timeline.

I don’t know why this is happening, and it does not make any sense for me. I installed the app on the @LeanSurvey account, and got the Customer and Token codes for that account.

I logged on a different computer, deleted everything (the app and the codes from the website), created the app again, generated new codes, and still the @salaroli_ is showing

Do you have any idea why is this happening?

Sorry if I could not answer the questions you just did, I’m not a developer

Thanks for the help


#4

Probably you did this procedure logged with @salaroli_ user. Please, can you try:

  • Log out Twitter (or enter an incognito window)
  • Go to apps.twitter.com
  • Log in with @LeanSurvey account
  • Follow the steps the Wordpress theme is asking you (Fill the form, create access tokens, etc)

Thanks