Twitter API and V3C Validator


#1

Hi, I am attempting to get a website validated for W3C for one of my clients. I have the site validator apart from the Twitter API I have installated. The follow code calls the API:

And I am getting the following errors:

Warning Line 1136, Column 229: cannot generate system identifier for general entity "include_rts"
Error Line 1136, Column 229: general entity “include_rts” not defined and no default entity
Warning Line 1136, Column 240: reference not terminated by REFC delimiter
Warning Line 1136, Column 240: reference to external entity in attribute value
Error Line 1136, Column 240: reference to entity “include_rts” for which no system identifier could be generated
Warning Line 1136, Column 243: cannot generate system identifier for general entity "callback"
Error Line 1136, Column 243: general entity “callback” not defined and no default entity
Warning Line 1136, Column 251: reference not terminated by REFC delimiter
Warning Line 1136, Column 251: reference to external entity in attribute value
Error Line 1136, Column 251: reference to entity “callback” for which no system identifier could be generated
Warning Line 1136, Column 269: cannot generate system identifier for general entity "count"
Error Line 1136, Column 269: general entity “count” not defined and no default entity
Warning Line 1136, Column 274: reference not terminated by REFC delimiter
Warning Line 1136, Column 274: reference to external entity in attribute value
Error Line 1136, Column 274: reference to entity “count” for which no system identifier could be generated

Has anyone come across this and is there a way in which it can be solved?

Thanks
Fraser


#2

It sounds like you have an escaping problem. More context would be helpful.


#3