Twitpic - Error 401 since couple of days - before working properly


#1

Hello,

We are using the Twitter and Twitpic API since several months, everything was working fine - until a couple of days ago.
Since then the final upload of an image to twitpic does not work anymore. We receive the error 401 - "Could not authenticate you (header rejected by twitter)."
It seems like there is a problem by passing the oauth data, packed into the header information of the post request to twitpic, to the twitter api endpoint.

However, nothing changed on our software - even if we take an old version of our software that used to work just fine with twitter/twitpic, it does not work anymore!

Has anyone else experienced this problem?
Any suggestions / solutions are very welcome.

Thanks,

Boris


#2

Hello,
i experienced the same thing.
how could you solve this problem ?
i have to test my APP for demo… after few days.
Share the solution, please.


#3

Hi there,

I found a solution for that problem - it was related with twitpic.
After submitting a request to twitpic, the twitpic staff told me that they changed the behavior slightly.
Before they passed the X-Auth-Service-Provider required by twitter automatically to twitter - since a couple of days, they removed it.
All you have to do is to pass the additional header X-Auth-Service-Provider with the value: “https://api.twitter.com/1/account/verify_credentials.json” - but be aware that this value must not be percent-encoded!

Cheers,

  • Boris

#4

Sometime this problem from your connecting server. Connected server disable the port such api, change the internet server, you will connect to twitpic api.


#5

https://api.twitter.com/1/account/verify_credentials.json - no longer seems to work, however, it works well with https://api.twitter.com/1.1/account/verify_credentials.json


#6

I have been having the same problem since yesterday. Because its recommended for use with Macs, I prefer to use Safari. Having read the comments above, I tried uploading via Google Chrome, and it worked. It’s really annoying that Twitter didn’t bother to tell their users about the changes they’d made, which might have saved hours of frustration.