Tweets not showing up in hashtag


#1

I run our company twitter page and we use a # for a daily tweet that we provide. However, when clicking on the hashtag only our last 5 or so tweets show up (this updates as time goes on) along with some from months ago.

I’ve read the rules and we are apparently following them all in terms of filtering, could you either tell me what I am doing wrong or unfilter us. We have nearly 1000 followers so I don’t think we’re in the super low group.

This is incredibly frustrating. I would understand if other people were using the hashtag or if they weren’t getting retweets and favorites but they are so I’m totally perplexed by the situation.

I’ve tried calling and submitting tickets (3 times, just to get an automated response telling me to go to the help page)


#2

What’s the hashtag? And can you point me at an example of a tweet which exists but doesn’t show up in search?


#3

https:// twitter.com/prfsn/status/506794990891462656

It won’t let me put the link in so I put a space before twitter

and it’s #fusionfact


#4

OK, that tweet’s just too old to be in the search index. The index contains all of the tweets from the last 7–10 days. Further back than that we index only some proportion of tweets (the ones you see from months or years ago).

This may change at some stage but for now you can’t reliably get 2-week-old tweets from Twitter Search.


#5

Is there anything we can do to help us get indexed?


#6

There’s not, I’m afraid.


#7

Is there a reason that some ones are randomly being indexed when others aren’t?


#8

Yes. It’s not random, but these are internal product details we don’t ordinarily share.