Tweet button suddenly not working



Hi, I have a tweet button on all articles on my site and today it suddenly stopped working. Rather than the button, I just get the “Tweet” text and if I click the link it only contains the URL, no text, no “via @…”

Has something changed? Any clues on how to resolve this greatly appreciated.

Here’s a sample link:


Looks like this is working on your site now. Let us know if this is still an issue.


Thanks. I suspect that is because I read other threads on this and updated mootools. And while that resolves the tweet button issue, it broke all kinds of stuff in the backend of joomla, making it so I can’t even update the site.

At the moment, I’m switching between mootools versions each time I update, but that’s definitely not a solution.

Any other way around this? Others having this same problem?


ps-aside from mootools-core.js, I also have mootools-core-uncompressed.js. Do I need to do anything with this? (I haven’t touched it)

There are also a few more mootools files I haven’t touched, mootools-more, mooRainbow, mooTree, each also has an “uncompressed” version.

Thanks for your help.


A Joomla plugin may help you enable and disable MooTools to place it only when needed. If you need MooTools in your Joomla backend but have no need for the extra JavaScript on the frontend a plugin may help.

The -uncompressed file contains the same JavaScript as the file without the suffix. The uncompressed version has better spacing for readability, helping developers; the regular version removes spacing to decrease file size. The uncompressed version is sometimes used when a CMS setting of developer mode or debug is enabled.


Thanks for your reply. Unfortunately, my menu is using mootools so I need it in the frontend.

If I install the new nocompat version, it breaks the menu plus so many things in the backend that I can’t update the site.

If I use the previous version, the tweet button doesn’t work.

If there is no other work around, I may have to remove the tweet button, but I would really rather not do that.


Yay Twitter! Everything is working again so I assume you did something on your end.