Tweet button events not firing in Internet Explorer 9


#1

This has previously been reported as issue 88 and supposedly fixed (by saying it was down to a missing doctype)

But it does not work for me in Internet Explorer 9, irrespective of the doctype

The bug is that tweet button events are not firing - ie that twttr.events.bind(‘tweet’, …) is not working

There is a simple test page here:
http://reallyeasyftp.com/test.html

It works OK in Firefox but not in Internet Explorer 9

Is this a bug in the twitter.com code - or is there something wrong with my HTML page?


#2

Same here. Tweet event is not firing in IE9. Tried all suggestions I googled, including adding DOCTYPE and making sure it’s the first element on the page - doesn’t work.

Works fine in Chrome, Safari and FF


#3

We also have the same issue with tweet button on ie9 , saying array is undefined.


#4

The tweet button in the Google toolbar works for sharing a webpage to
twitter. I’ve tried other widgets/buttons without success.


#5

I am under the same experience using IE 8.0.7600.16385. So far I could twit twice by indirect ways it seemed, I didn’t have the occasion to become handy at this all yet.

I fear to be mistaken for a spammer because I am often refreshing pages to show just the toolbar and background. To no avail until today, glad I found this topic finally.

There is this “error on the page” thing. Hope it get fixed :wink:


#6

“It works OK in Firefox but not in Internet Explorer 9”

Figures.

I’m not saying, I froze at the hundreds of MB from MS update to grant my pc IE9. No not that way thanks.


#7

I, erm, fixed the issue by installing Firefox. My twitter seems normal finally.


#8

I am experiencing the same problem in IE. Any ideas on how you guys, fix it?


#9

I am experiencing the same issue! Must have been a silent release!


#10

#11