Tweet button count not working


#1

Hi all,
I’m having great difficulty getting the count on my Twitter buttons to work. I know there have been some clicks on http://www.appliances4.me/page/11/DAB-radios.html but the count is not increasing(I have waited for days for the cache to update), nor does anything appear in the search for that URL.
You’ll notice on the home page http://www.appliances4.me/ there are some tweets registered from the past but that may have been when my sites were on a dedicated server, they are now on a shared server with mod_security installed which I think may be the issue, unfortunately there is absolutely no way I can get this removed.
A call using “curl -I” returns a 406 Not Acceptable message, however a call using “curl -A Apache -I” returns a 200 response, I have tried replacing “Apache” with “A” and I still get a 200 response so it just looks like curl requests need to specify an agent, regardless of the value.
My suggestion is (and I’m sure this will help many people as I have seen a lot of other messages along these lines) to make sure any curl requests sent by Twitter are sent with a user agent specified, this should alleviate a lot of problems.
Please let me know your thoughts and/or whether there may be anything I may be able to do in my headers which will allow the clicks to be properly counted.

Thank you

Kind regards,

Thomas Findlay


#2

Is there anywhere more suitable I should post this message for the Twitter developers? I’m sure my small tweak above will help out a lot of people so I’m keen to try to get it implemented.

Thanks


#3