Tweet Button count not updating


#1

We have a tweet button with a count that for some reason or another sits at 0. There are a couple things going on that I know can cause issues, but I’ve tried different variations to no avail.

Here is the site with the button in question: http://kmart.com/home
and the current (AddThis) configuration:

The site does issue a redirect, so I’m using the ‘counturl’ to specify the resolved url. The page also has a canonical url (http://www.kmart.com/kmart-home/dap-120000000200400), which I know can sometimes be the problem, but setting that as the ‘counturl’ didn’t seem to work either. We are using AddThis, but the problem doesn’t seem to be on their end - generated markup looks fine.

Another thing I’ve noticed is that the count link takes you to a search by the ‘counturl’:
https://twitter.com/#!/search/realtime/http%3A%2F%2Fwww.kmart.com%2Fshc%2Fs%2Fdap_10151_10104_DAP_Kmart%2BHome (yields no results)
as opposed to the ‘url’:
https://twitter.com/#!/search/realtime/kmart.com%2Fhome (yields the actual button tweets)
which seems backwards. Is this expected?

Oh, and the page with the button is in an iframe. Not sure how that would affect it, but thought I should mention.

Anyway, any help or insight would be very much appreciated. I’m out of ideas. Thanks!


#2

Hi Adam,

We’ve recently changed some of the back-end architecture in regards to Tweet Button crawling and counting, and I’m not sure if there may be a new quirk in this or not – I have some questions out to our developers to clarify a few things. That said, I can help a bit by just running through how I think we’re seeing your issue from our side:

We can’t typically help with the AddThis-specific markup as you’ve presented here – can you share what the exact markup it generates that would be comprable to primary use of the Tweet Button instead? It’s usually best to avoid the IFRAME approach, as well as using mediated solutions like AddThis.

Looking at the site and the configuration you have, this is what I think you’re telling the Tweet Button:

With this logic, we would assume that http://kmart.com/home is going to ultimately redirect to http://www.kmart.com/shc/s/dap_10151_10104_DAP_Kmart+Home – but in reality, http://kmart.com/home redirects to http://www.kmart.com/home which then redirects to http://www.kmart.com/shc/s/dap_10151_10104_DAP_Kmart+Home – I have a question out to our team on whether this many redirects would be followed for this chain.

Compare to an example like a TechCrunch article: http://eu.techcrunch.com/2012/01/09/challenging-amazon-netflix-debuts-5-99-video-streaming-service-in-uk-ireland/


#3

Thanks for the quick response. Per your suggestion, I’ve updated the button to use “http://www.kmart.com/home” to see if that makes a difference (may take up to an hour to propagate, since this is hosted via cdn).

Also, here is the comparable native tweet button markup:
Tweet

I could definitely take out the AddThis if necessary, but would like to keep this as a last resort. And unfortunately, I don’t have much control over the iframe setup (def not ideal I realize).


#4

Hi Taylor -

Just wondering if there was any feedback from the developers. Tacking on the “www” to the share link doesn’t seem to have made a difference.

Thanks again.


#5

Im having the same issue, it tweets, but stays at 0. Is this something that will pick up at some point or should i see the number change right away?


#6

same issue here, with tweet count staying at 0 and the link to “View More Tweets” takes you to the incorrect page.

My set up is similar with,

  1. different values for “url” and “counturl” parameters
  2. The “url” parameter does two 301 redirects

Interestingly enough, I noticed that the in the “src” attribute of the resulting iframe, the “counturl” param is absent when I use the real url.

But, when I set both “counturl” and “url” parameters to the url that does two 301 redirects, then the “counturl” param reappears in the “src” attribute of the resulting iframe.


#7

I deleted all my tweets but it still says I have 25,589 tweets. How can I turn it to 0?


#8

Thanks !


#9

Hello, episod,
I met similar problem. I used share button,
Tweet

my twitter url is http://www.irisyan.com/iptvepg/web/sns_share.jsp?pcode=0000000030010000012462&ptype=1
when I click 0, it show the results.
when click this twitter url, it will redirect to another server and the final url is “http://epg152.irisyan.com/iptvepg/frame112/vod_auth.jsp?pg=0000000030010000012462&cc=0J0002&pt=1&cn=Trailer&pd=&mi=3&ix=3”, must I set counturl to the real page? even if I change to this page, the count is still 0
can you help me?
Thanks!


#11

Hi, I am having the same issue on the Housing Works advocacy website. I embed the share button at the bottom of every blog post, and while the tweet itself works and can be posted, the number count never updates, so it’s just sitting there at 0.

I’m creating these on a weekly basis for blogposts and it would be useful for the count to work so we can track and monitor what’s actually shared.

I tried to post the embedded code your system is spitting out when I create these, so you can isolate the problem, but this posting system turned the html script into something else the first time I tried to send this msg, and this forum won’t allow me to upload a screenshot of the code either. Please advise.


#12

Has anyone been able to solve this yet? It seems like lots of people are having this problem, and there is no working solution. I have the same problem on a website that I am working on. I share something using a twitter share button and the count never updates. It’s shown as 0 for over a week. If I click the 0 it claims that the page has never been tweeted, but if I go into my account I see it at least twice.

I’ve searched the Internet for a long time for a solution to this and have seen tons of posts from people having the same problem, but none of them seem to have a solution.


#13