Tweet button count is not counting


#1

I added a twitter button on our website and for some reason the count stays at 0. From what I can tell we have HTTP Head requests and I have added the data-counturl to the resolving page. We are using bit.ly to shorten the url. We tried keeping the url how it was hoping the t.co would shorten it but it keeps telling us the tweet is too long.

Anyway, any help would be appriciated. Here is a link to a page where we tested using the tweet button with 3 peoples twitter account and it still shows as 0.

thanks
Cannn


#2

It looks like the count is incrementing now, so maybe this was just a stale cache of the count. Keep in mind that even if you’re using bit.ly, all URLs will be wrapped in 20 character long t.co URLs, which probably explains your Tweet length issues.


#3

We have checked about the tweet count doesn’t advance when article is tweeted.

By default its taking time to increase the count from twitter site. Because http://cdn.api.twitter.com/1/urls/count.json?url=http://www.cntraveler.com/daily-traveler/2012/02/Sunrise-from-California&callback=twttr.receiveCount
response is delay.

We have verified the other sites also. The same issue is reflected.

Please let us know how to proceed.


#4

Hello. Until 3 days ago my blog Tweet button worked fine. Now it registers zero although I can retweet to Twitter. That registers but on refreshing page the number returns to zero. I tried pinging but it said my URL wasn’t registered. Checked that to find it is but says there are no tweets.

I know I get several re-tweets from each post as I see them on Twitter.

Haven’t installed any new software or anything.

I’d be pleased if you could help. http://subrosa-blonde.blogspot.co.uk/


#5

Although I am truly terrible at this stuff, I understand the basics of these codes. Can you please explain to me what part of this “share on twitter” code is incorrect and not allowing the count to go up?

Tweet

Thank you


#6

Hi @shoregasmic,

You’re using the same shortened url for both the data-url and the data-counturl values. You’ll want to make sure the data-counturl points to your canonical URL for the page – usually your unshortened URL.


#7

got the same problem on my site, tho I used WP plugin called “Really simple Facebook Twitter share buttons”


#8