Trying to transfer an API key but can't access the form

login
api

#1

Hi, I’ve just started working with the Twitter API with a little literary Markov bot project, and I’m now trying to transfer the API key for the app I’m building to a dedicated account. But, upon visiting the appropriate support form, I get immediately logged out of twitter and can’t log back in to support.twitter.com (I just get the “You must be logged in to do that” dialog). Oddly, I have no issue signing in to any other part of Twitter, just support.twitter.com. I don’t think it’s an issue on my end, as I’ve tried every browser I have on every device I own, and still run into the same problem each time. I spent all morning trying to find a way to file a support ticket for this issue but couldn’t get anything other than a password reset autoresponse. If someone here might be willing to help me out figure what went wrong, that would be amazingly helpful. Thanks!
-viv


#2

You should be able to create new keys for the app without filing a support request. What I generally do is

  • create an application under my main account,
  • create a Twitter bot account (through the website), and then
  • get API access keys through a program like this, using the consumer_key and consumer_secret from step one while logged in to the bot account.

That last bit is important, since you’ll be authenticating with Twitter through the website. If you’re logged in to your main/personal account, you’ll get back access keys for that account and your bot will start tweeting as you.


#3

Thanks a bunch, ended up trying this out and it worked like a charm. Will definitely be doing it this way in future rather than trying to transfer keys.


#4

Awesome! If you’re making twitter art bots, definitely check out the # botally hashtag too! There are lots of great folks making cool things.