Trouble Getting Started with Fabric and Twitter Kit

android
fabric
api

#1

Hi - I just installed Fabric for Android Studio but I’m having a problem getting it to work.

In my code when I try add this:

import com.twitter.sdk.android.tweetui.TweetTimelineListAdapter;
import com.twitter.sdk.android.tweetui.UserTimeline;

these classes are not recognized. I tried to resolve this by adding to my gradle file:

compile(‘com.twitter.sdk.android:twitter-core:1.3.1@aar’) {
transitive = true;
}

but still it’s not working. Any suggestions would be appreciated!

Thanks,


#2

Thanks for reaching out on this @zzzmikedogzzz, seems like something odd happened during the install, but check out the full steps here: https://fabric.io/kits/android/twitterkit/install


#3

TweetTimelineListAdapter and UserTimeline are not in the twitter-core dependency. They are in the tweet-ui dependency.

compile('com.twitter.sdk.android:twitter:1.14.1@aar') {
  transitive = true;
}