Tracking $STOCK symbols doesnt return any tweets over streaming api?


#1

Using just the regular filter track demo PHP in Phirehose to track keywords with the $ character for stock symbols like $AAPL etc, doesnt return any tweets at all over the streaming api? I have tried lowercase ($aapl), uppercase ($AAPL), ‘%24aapl’ and so forth, without any resulting tweets coming in. If I track just AAPL without the $ character, I get streaming tweets. So the source code for streaming in general works. Am I missing something fundamental about tracking the stock symbol keywords?


#2

Might be an issue with how PHP is encoding the request?


#3

Igor, thanks. Unofrtunately not, did a debug printout of the URL that phirehose assembles and uses to request the tracking, and the URL says “…%24aapl%21%24yhoo” etc. Could it be FILTER_LEVEL that prevents stock symbols from appearing?


#4

That might be it - just tried connecting with $appl, $goog, $amzn … most of them are “filter_level”: “low”

My POST Request looked like this (without oauth stuff):

filter.json&count%3D0%26stall_warnings%3Dtrue%26track%3D%2524appl%252C%2524goog%252C%2524amzn%252C%2524fb%252C%2524yhoo%252C%2524msft%252C%2524tsla%252C%2524nflx%252C%2524twtr

(Using Twitter4J)


#5

Did you then get the streaming tweets for those stock ticker symbols? Hm, still cant get it to work in PHP using Phirehose.


#6

Yeah I got tweets coming in, though they didn’t seem to be that frequent - only a tweet or 2 every minute or so (although i only ran it for few minutes, and the volume will vary depending on a lot of things)

One thing to try might be to use https://dev.twitter.com/streaming/reference/post/statuses/filter “manually” - with the “OAuth Signature Generator” & curl. Might help check if it’s the library or something else.


#7

Thanks Igor. Yes, I have tried that manually (and it works), and the url there is formatted just the same as the one Phirehose generates (when debugging), mystery continues…


#8

This is strange, trying to track $fb, $aapl and so forth, using the twitter development console on their website, doesnt work either… I get no streaming tweets for those trackwords. Having the same search going in TweetDeck at the same time, I do get tweets. So tweets are being done by users out there.