TIP: Twitter Timeline Widget Fix - not showing - wordpress - drupal - not working


#1

I spent 2 hours trying to figure out why my new Twitter Timeline Widget wasn’t showing up on my Drupal site. I double and triple checked that I copied the code correctly and that my web site (www.WashingtonIsBroke.com) was added to the widget. I tried clearing the cache… I tried it on 3 different browsers. I tried putting the block in different sections of the page… nothing… just the link “Tweets by @WashingtonBroke” showing up. I searched the web (how I got here). I searched Drupal.org. I searched this site… nothing… Then I noticed my URL on my browsers weren’t showing the “www” in front. I thought “That can’t be it… surely Twitter assumes with and without ‘www’”. Um no. I added “www” the the URL and it started working. So I went back to my widget and added my website domain without the “www”. Whalla… works like a charm.

So, make sure you have your domain name WITH and WITHOUT the www, I.E.

www.WashingtonIsBroke.com
WashingtonIsBroke.com

Thank me (in my Mark Levin voice)


TIP: Embedding TImeline Not Working
#2

Thank you!


#3

This didn’t help. But glad it worked for some.


#4

I found that the src link to the widgets.js didn’t have the “http:” in it, so the page was looking for a file instead.
When I copied from Twitter it looked like this:
js.src="//platform.twitter.com/widgets.js

I modified it to this:
js.src="http://platform.twitter.com/widgets.js

…and it worked (albeit localhost).


#5

^^^ Legend


#6

Where is the “domains box” everyone is talking about? There is no such box on the Widgets page in twitter (https://twitter.com/settings/widgets/new/user). Where are you guys going to set your widgets up?


#7

Found a solution, for Drupal anyway, you need to add the following into your page header:

Then the widget embeded in the middle of the page starts working. I’m not sure why the code in the widget doesn’t work since it looks like it’s supposed to do the same thing, but I guess it’s just broken at the moment.

Hope this tip helps someone else :slight_smile:


#8

Hi. I am a complete N00b when it comes to drupal. I am helping a friend out because her twitter feed is not loading. I have search on google for some simple instructions on what to do to resolve this problem. I would so greatly appreciate some directions on what or where to go to find out how to resolve this. This is the website. http://immanuelhouse.org Thank you so much in advance.

@juliebirdsong


#9

My Twitter Timeline just broke today, was working fine until yesterday or the day before. Adding “http” or “https” doesn’t do anything. If I try to inject the script manually into the page using Chrome’s Console, I still get some kind of an error:
(anonymous function)
InjectedScript._evaluateOn
InjectedScript._evaluateAndWrap
InjectedScript.evaluate


#10

Hi I have the a very similar problem to @CappellaniaR3’s
I changed my timeline because it was old and twitter changed the code to put on the website. After that it works on firefox
, ie, but not in chrome (my version is 30) Below is my code, with the changes I did
Greetings and thanks

!function(d,s,id) { var js,fjs=d.getElementsByTagName(s)[0]; //p=/^http:/.test(d.location)?'http':'https';
if(!d.getElementById(id))
   {
	js=d.createElement(s);
	js.id=id;
	//js.src=p+"://platform.twitter.com/widgets.js";
	js.src="https://platform.twitter.com/widgets.js";
	fjs.parentNode.insertBefore(js,fjs);
}

}
(document,“script”,“twitter-wjs”);


#11

I had a virtually identical problem, none of the above fixes helped.
Turned out it was just because I had the AdBlock extension turned on in Chrome, hence it working in all of my other browser. Never know, might help someone else.


#12

I thought I had already replied but maybe not; turns out that for me it was the Avast Web Security plugin for Chrome. Once I disabled that, my Timelines worked just fine.


#13

#14