Timestamp out of bounds Error


#1

Hi,

I’m getting {“errors”:[{“message”:“Timestamp out of bounds”,“code”:135}]} when I typed the following into my browser. All the values of the parameters I have are from OAuth Tools in my app.

https://api.twitter.com/1.1/statuses/user_timeline.json?screen_name=xxx&count=3&oauth_consumer_key=xxx&oauth_nonce=xxx&oauth_signature=xxx&oauth_signature_method=HMAC-SHA1&oauth_timestamp=1373897665&oauth_token=xxx&oauth_version=1.0

I was browsing the internet and tried to find a solution, but all I found is that the possible cause is that my server time and Twitter’s server time don’t match.

Since I’m just typing the url into my browser, my server’s time is just my computer’s time. So I changed my computer’s timezone to UTC (that’s what I saw from the “date” header in Twitter’s reponse) and I adjusted my computer’s 3 seconds faster to try to match Twitter’s time.
After all the tries, I still got the same error.

And at the same time, my live service’s time seems to match Twitter’s service time, too. And it’s not working in my live server as well.

The above url originally worked right after I generated it from OAuth Tools, but after some time (about 2 hours) it didn’t work anymore. I don’t want to go to the OAuth Tools page to re-generate all the key, nonce, signature and tokens everytime it stops working.

Thank you