Timeline widget : What am I doing wrong?

embeddedtimeline

#1

I can’t get the new Twitter timeline embedding feature to work.

Apparently anybody can embed anybody’s Twitter timeline now, providing said timeline is not “protected”, which is the default setting anyway. I tried different accounts, the @TwitterDev one, several, no luck: Only a text link. I built test pages, tried different browsers, and even different web server. I can’t imagine that the service itself could be broken for days like this, so I must be doing something wrong, I’m really asking for help here.

Logged on, in the “Settings and privacy” menu entry, there is a “Widgets” tab that gets you to a page that says “You currently have no widgets” with a “Create new” button next to it ; Clicking said button produces a menu where choosing “Profile” (is that how you create a timeline widget?) takes you to a page where you enter the name of the user whose timeline you want to embed.

There are examples, it’s really a simple wizard, you can seemingly embed anything, without any specific id.

Then, a message saying “That’s all we need, unless you’d like to set customization options ; By embedding Twitter content in your website or app, you are agreeing to the Developer Agreement and Developer Policy.” end of quote, emphasis mine ; and here is the code snippet :

Tweets by TwitterDev

Of course, I tried prefixing the URL with http or https, but I also know that the ssl-agnostic “//” prefix is the good practice, and of course that changed nothing :frowning:

Now at this stage, if you go back to you “widgets” settings tab, it still says “You currently have no widgets.” so, hum :confused: And here is what happens when I copy and paste the code snippet :

https://jsfiddle.net/wr6y60xo/

Only text links are displayed, the timeline is not rendered. The external JS script is pulled in OK though, I checked.

Am I missing something here? What is going on?


#2

Allright, it is a security problem, most notably Firefox (53.0 64-bit Linux) blocks the rendering of the widget. To unblock it, click on the shield icon next to the URL/Location bar, and click on the “disable” button.


#3

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.