Timeline widget stopped to show pictures


#1

I use the Timeline widget to embed Tweets in my forum (Running WoltLab Burning Board 3.1.8 on Apache). This forum software offers portal boxes where you can add the widget code. That worked for a pretty long time now, but since one or two days the Tweets are shown without the picture. There is an empty placeholder which redirects to the picture if you click on it.

Nothing has changed regarding the forums software. If I embed the widget code on other Websites it works. So I donÄt think this is an browser or widget issue. What could be the reason?

The forum log files didn’t reveal anything.

AWo


#2

A timeline widget created on Twitter.com includes an auto-expand photos option. This preference is stored for the widget ID and may be changed by visiting the widget settings page for the Twitter account which created the widget.
https://twitter.com/settings/widgets

An example user timeline for the TwitterDev username with the auto-expand photos option selected.
http://jsfiddle.net/pb5zpwc6/


#3

I am experiencing a very similar issue.

I have 3 separate twitter widgets on my ESPN Fantasy Basketball homepage which have works flawlessly for for at least 2yrs. (2 are based on a user, 1 on a list). As of yesterday/today members of the league are unable to view images posted in tweets. All images are white with a questions mark in them that says “click to view on twitter”.

This issue is occurring in the following scenario’s:

  • MAC running Safari (OS/Browser are up to date)
  • MAC runnings Chrome (OS/Browser are up to date)
  • iOS (iPhone and iPad) device runnings safari (OS/Browser are up to date)
  • iOS (iPhone and iPad) device runnings Chrome (OS/Browser are up to date)

(I haven’t tested from any other devices as of yet i.e. Android and windows)

Has something changed? Ive re-embedd the code for all 3 widgets to no avail…


#4

Same problem here! The twitter widget embedded in my website suddenly stopped to display images (only a white box with a “click to view on twitter” message). I am on a Mac with OsX 10.7.5 and Safari 6.1.6 (7537.78.2), Chrome and Firefox (both up-to-date). I tried to re-embed the html code with no success. Can anyone help on this? Thanks!


#5

Yep, it’s a problem on Twitter’s side - their platform.twitter.com/widget.js is returning undefined for one of it’s functions - hope they fix soon.


#6

Note, if anyone at Twitter reads these - the src tag for the image value is returned as “undefined” from platform.twitter.com/widget.js


#7

The Widget was not visited, so settings weren’t changed. The picture is expanded but not displayed (empty frame). However I deleted and created a new widget, same behaviour. If the problem comes from Twitter, why does it work a Wordpress homepage, but not in the forum?

AWo


#8

For those of you experiencing problems, would you mind sharing a URL to a page that demonstrates the problem? Or if you cannot do that, an id of an embedded timeline that’s exhibiting this issue would also be helpful.


#9

Not Working: http://www.landyfriends.net/foren/index.php?page=Portal
On the left side is a box wich shwos the Tweets.

Working: http://www.best-4x4xfar.de
On the right sidebar.

AWo


#10

IE is defaulting to document mode 8 on the landyfriends but is defaulting to edge on the best4x4. That is the issue. Twitter widget javascript for document mode 8 has been removed. I don’t have a solution for this though that I can think of


#11

Issue here:

Note, exact same embed works fine in subdirectory on same site, ex:

data-widget-id=“452098269447876610”


#12

I have exactly the same problem on the following website:

www.msll.ca

Photos were working fine up until Wed 14th Jan. Now all photos are displayed as a blank placeholder.


#13

This is the site that is experiencing problems (MBA with OsX 10.7.5 and Safari 6.1.6 (7537.78.2), but also Chrome and Firefox, both up-to-date).

http://www.lem.sssup.it/fagiolo/Welcome.html

Thanks!
Giorgio


TWITTER - 2015 - Uncaught TypeError: Cannot set property '[object Array]' of undefined widgets.js:1
#14

All of the web pages shared in this thread that are experiencing issues are using prototype.js 1.6. That library overrides Array.prototype.reduce with a non-standard implementation which results in widgets.js setting the source of images to undefined.


Twitter feed Widget broken
#15

So how do we fix it or is it a twitter side issue? Tks for your help


#16

Updating the version of Prototype used on your site should fix the issue immediately.

Embedded Timeline with Prototype 1.6.0.2:
http://jsfiddle.net/qpbbzhyo/

Embedded Timeline with Prototype 1.7.2.0:
http://jsfiddle.net/2zrkLcq3/

The Array reduce method was removed from Prototype in version 1.6.1 (August 2009).

Google offers hosted versions of Prototype; simply swapping out the script src may help ease your upgrade path.


#17

Huh…ok…can you give some more help? Seems that I need to edit a file or so…sorry, I’m not a developer…
How do I do what needs to be done…more practically…?

AWo


#18

In addition, there is no prototype.js on my server…
I did a complete file scan.

AWo


#19

Hi Niall, thanks for your post, do you mean that we should embed this

script src=“https://ajax.googleapis.com/ajax/libs/prototype/1.7.2.0/prototype.js

in our html? where exactly? So far I tried without success.

G

UPDATE:

Thanks Niall, problem solved here. I did not have Wordpress or similar either, just plain website (originally created with iWeb, now deprecated). What I did was to replace the content in the file <iWebSite.js> (which I’ve found in my folder on the server) with the new content copied from https://ajax.googleapis.com/ajax/libs/prototype/1.7.2.0/prototype.js; now et seems to work flawlessly (until the next upgrade I guess!). I hope this may help also others with the same problem: practically what you have to do is to look in your server for a .js file containing the prototype (st starting with “var Prototype={Version:” I guess) and replace the whole content with that in the file https://ajax.googleapis.com/ajax/libs/prototype/1.7.2.0/prototype.js I am not an expert, so probably what worked for me may not apply to others!


#20

Hello! Any help on fixing that practically…I’m somewhat lost here…

Thanks!
AWo